Flipped normals for glTF

Hello, I’m trying to do this trick in this tweet where I can have a see through sphere using flipped normals for glTF models, it works right away when I use a simple sphere and a cube

works great, but then I added a black material to the sphere to make the inner sphere black, and it removed the see through effect

the normals are still flipped so i don’t understand why would it stop working when you add a material

When I export a sphere with inverted normals and a black material, it shows expected results for me:

Could you share a simple blend file with reproducible results of the issue you’re having?

Gltf broken.blend (3.1 MB)

here it is

extra info, I’m using this glTF viewer https://gltf-viewer.donmccurdy.com/

here’s the working glTF
norm.glb (532.0 KB)

here’s the broken one
norm1.glb (532.2 KB)

blender version 3.1.0

Finally got the export to work from your shared blend…

Apparently the rendering engine you were using, Cycles, doesn’t necessarily support back-facing - but EEVEE does. Which is the engine I chose to use for the final export as shown in the screenshot.

Gltf broken_rp.blend (3.1 MB)

Gltf broken_rp.glb (47.4 KB)

1 Like

Thank you! so basically just changing the engine to eevee before exporting is enough? or is there another step in the proces

[edit] figured it out, it seems like you need to use basic materials and not nodes, so by clicking the toggle on nodes in the material tab you get the extra options