Flipping normals won't work?

(bigkahuna) #1

Maybe I’m doing it wrong, but in the edit mode I’ve selected all the poly’s in my model and then select either Mesh > Normals > Flip or Mesh > Normals > Recalculate outside/inside, and nothing happens. I’m working with meshes that were exported from another application and the poly’s normals are flipped and I’m trying to fix this in Blender. Tried fixing it in 2.43, 2.44 and 2.45 with the same result. Am I doing something wrong?

Thanks!

0 Likes

(BlendRoid) #2

Make sure they actually aren’t flipping, as something else may be your problem. In the editing buttons, press “draw normals” and crank up the size a little. Then try flipping the normals again and see what happens.

0 Likes

(Cire) #3

Sometimes normals problems can be fixed by applying scale/rotation (Ctrl+A) in object mode first. Try that, then flip your normals in edit mode.

.

0 Likes

(bigkahuna) #4

You were right. It wasn’t the normals, but something weird with the display. The model is pretty high poly (18,000 polys) but when I reduced the poly count and applied a texture it looked as it should. Thanks!

0 Likes

(Duoas) #5

I think the most likely problem was that the imported mesh was non-manifold, meaning that somewhere you’ve got an edge sharing more than two faces. This problem can occur as a result of importing too…

It seemed to me there was a script somewhere that could find such problems, but I don’t remember where it is right now…

0 Likes