Floating orange/red dots, help!

Hi, I’m incredibly new and have no idea what I’m doing and I’ve been ok on my own so far until these random orange/red dots popped up and it doesn’t matter what mode I’m in, they’re always there!


I was trying to split part of my mesh after accidentally merging it and after trying a few things I just gave up and deleted the small section and that’s when the dots showed up.
I tried W and P and things to try and “un merge” the point before they appeared. I can’t select them at all and I’ve even deleted my entire model and they’re still there. I’m on a mac if that changes anything.

Thank you!

Attachments



It would be much easier if you’d just upload the .blend file here. As far as I can see here, those orange dots are other objects in your scene, check in outliner if you have more objects in your scene than you can see them. You’ll be able to detected and deleted unwanted objects in your scene by using outliner. It’s in the top right corner of blender.

they look like vertices? Have you tried “removing doubles” that could fix it…

That just indicates where the object center is. In object mode, the center of manipulation goes around that point. I believe there’s a way to toggle its visibility if too distracting. Try checking the properties panel.

that is incorrect paul, hes not talking about the origin point.
if you look closely, there are even smaller orange dots.

they look like grease pencil, or a mesh as secondary selection while in edit mode.

try the following steps:
press N, go down to grease pencil, and uncheck it. if that does not help, go into object mode, and press A once or twice untill everything is unselected. if that did help, look through your outliner (https://gyazo.com/95d734b260dfcbae0c0a035f26983551) and delete everything that is not supposed to be there.

if neither of those helped, then you have to upload the blendfile.

Ahhh… Ok, they didn’t show on my screen at all w/o opening the full size view.