fluid bug, or am i doing something wrong?

I’m trying to fill a container with a fluid.
i use a cube as an inflow and turn down its size to zero to stop the inflow. but somehow the volume of the fluid keeps increasing during the simulation.

I tested this behaviour with the official 2.42a and the current cvs version.

Here you can watch a sample video showing my problem.

Is this a bug, or am i doing something wrong here?

What sort of resolution are you baking at?
If it’s too low, the volume can be misleading. In fact if the resolution is too low, in some cases it may look like the fluid disappears altogether.
Usually I always make the final resolution as high as my computer will bear, which varies depending on the complexity of the simulation.

Another thing to try is maybe combining the scaling with an Active Fluid IPO. The Active IPO should be applied to the Inflow object (the one generating the fluid). Anything greater than 0 is ‘ON’, and anything equal to or less than 0 is ‘OFF’. (Thus, it’s best to set the curve ipo type to Constant).
(Shouldn’t really be necessary though - most likely problem is too low a resolution setting)…

Here’s an example file:
(You’ll need to adjust the path/file name to bake to)


Thanks for the answer, but i already tried different resolutions. That doesn’t seem to help. I will now have a look at the ipos you mentioned. didn’t know there were ipos for fluids at all :slight_smile:



Would it be possible to post a blend file on-line?

The only other thing I can think of is that sometimes if you place an Inflow Object even with the side of the domain it could cause issues/interactions. In these cases, just leaving a small space between the inflow Object and the side of the Domain will usually fix it.