Fluid Effector - Collision not working - thickness is ok

Hi All,

BLENDER - 2.90.1

I want to create a simple fluid animation like water goes on a path of an object.
Object is imported DAE file - meshes and normals are okkay checked it its a model from Revit ( also tried FBX but its not working with that type either)

File built like -

imported collada .dae file from revit
set the domain cube bigger than the imported object - is the fluid effector
than added sphere as fluid inflow to fall on the effector

Issue
Fluid goes thru the effector

Tries

  1. I tried rendering with eevee, cycles, and with workbench - not working
  2. I tried to solidify the imported object with some thickness - not working
  3. I replaced some parts of the imported - actually modeled 4 parts from native cube dimensioned and formed the same as the imported object -set as effector - not working
  4. i tried to change or flip faces in edit mode**- not working**
  5. I also placed a cube to the scene just reduce it - set as an effector - fluid goes thru - not working
  6. Tried to set effector substeps greater than 0 and set surface thickness greater than 0 as well still - not working

If I start from a raw model do the same without the imported object cube blocks the flow - If I import the object .dae to the scene cube still blocks the fluid fluid goes thru on .dae which was set as an effector.

Could someone please help ? like I dont know what am I doing wrong or what is happening here…
Its a kinda urgent matter cose I have to present this scene soon … :slightly_frowning_face:

you can download my file from here -