Fluid in Glass

I have baked some fluid at a resolution of 200 to get an idea of what the final render would be like (this is my first real Blender Project, btw).

Anyway, I want some of (and maybe if it looks better, all of) the fluid to go inside the glass; however, as you can see, there seems to be an invisible wall above the glass (which is set as an obstacle). What I want to know is how can I fix this? Is it simply because of the low resolution, or do I need to do something else?

Also, any tips on how to improve the focus on the glass would be appreciated. I attached a screenshot of my nodes setup.


  • Kenneth Powers


To solve your invisible wall problem, you need to make sure you have your glass obstacle set a free, tou also may want to try to make your inflow object closer to your glass or lessen the drop and maybe even shrink your inflow object.

Ok, I set the glass to free and it still didn’t work correctly. Here are some screenshots.


Ok, for some reason my reply didn’t go through.

I’m still getting the invisible wall problem. Here are some screenshots.

EDIT: Ok, for some reason there’s a big black block in my render that wasn’t there before. But there is still an invisible wall)


Instead of init both, try just init shell.

Heres what i got using your settings exept instead of init both i used init shell.




See the section entitled “Provide Bowl of Obstacle”, step 4.

I also have this problem.

thanks! Thangalin
I didn’t recalculate the normals outside,so I got the invisble wall problem.


You’re welcome. Hope to see the result soon!

nothing has worked for me concerning this issue. i tried everything. Init Volume, Shell, Both, everything. i still get the leakeage. PLEASE HELP!!!

Chances are good that the walls of your glass are too thin. Make another glass with thicker walls and run the simulation with that as your obstacle. That should solve your leakage problem. Then when you render, swap out the thick glass with the thin one.


If you created your cup using the Spin function, perhaps you forgot to “connect” the spun vertices together. In edit mode, select all vertices and press [w] > “Remove Doubles”. If Blender comes back with a message saying “Vertices removed: #” and # is a number that is not zero, it means you had some un-connected vertices lying on top of one another.

Once that is done, you should recalculate normals once again.

Also, contrary to what was mentioned elsewhere, it doesn’t matter what layer your obstacle is on, since the Fluid Simulation ignores layers (unlike the particle system).