Fluid mesh is invisible

Hello, everyone,

I had made a liquid simulation with the particles, mesh and all; then I had to check something so I unchecked the “mesh” part in the physics tab and when I clicked on that again my fluid mesh had become invisible, both in the viewport and in renders.

I know that the mesh is still there because I can see the outline of it when it’s selected and it changes with the frames; also the scene statistics say there’s about 1 Million faces.

Have I encountered a bug or am I missing something?
(This happens both in version 2.93 and 3.0beta)
I’ve been using Blender for a year now and I thought I knew how to not loose objects.

Thanks

2 Likes

Hey, MoonMattia. I’m having the same problem. Did you ever solve this?

1 Like

me too did YOU ever solve it? :sob:

UPDATE: I solved my issue. IF you turn on particles (like bubbles or spray) for your liquid, you NEED to make sure to tick “show emitter” ON THOSE particle systems.

The “emitter” for THOSE systems IS THE MESH OF THE LIQUID. So, it will hide your mesh if you have that off.

ALSO make sure to see there are 2 checkboxes - RENDER and VIEWPORT for each…