Fluid not touching obstacle

I am doing a simple fluid simulation of fluid falling into a box.

When the fluid falls into the box, it does not seem to ‘fill’ the box. It doesn’t touch the sides of the box, as if there is a smaller, invisible box containing it.

I have tried rebaking already.

Details:

The box is set as an ‘Obstacle’, and the volume init is ‘shell’. The domain surrounds the setup with lots of room to spare.

Hi,

Firstly, you don’t want lots of room to spare within the domain. You want the domain to be as small as possible, while still large enough to contain the fluid.
Next, you will need to increase the resolution of the domain to produce a fluid that more closely conforms to obstacles, but this will have a cost in both memory and speed. Don’t forget that there are two resolutions - one is the domain resolution, this will be used when rendering; the other is a preview resolution, and is used to display the fluid in the interactive windows. The preview resolution should be low enough that it doesn’t slow down Blender while you are still editing. When you render, your fluid should look better than in the interactive display.

You will need to increase the fluid resolution much higher than the default to get the fluid closer to the domain shape. The default is very low. Also set the display quality to final rather then the default preview. You’ll never get an exact match, its the way the fluid simulation works.

Richard

I increased it from 100 to 200, almost no difference. Still a big gap between the box and the fluid. I am using final mode.

Post your blend.

Here it is.

Attachments

fluids.blend (255 KB)

It looks like your preview resolution in still set to 25 in your blend and have tried rendering to see what it is actually doing?

set your resolution to 150 to save some time and try rendering out some frames,

The GUI display mode is final, so the preview resolution is irrelevant. I have tried rendering, and the result is still a noticeable, unrealistic gap.

Note you will always have a gap, it’s not real life and this is a result of how the simulation works. If you have a couple of thousand euros spare you can get Realflow.

There are some things you can change which will help.

  • Change fluid from a shell to a volume
  • Make the domain smaller to just surround the container
  • Change real world size to 0.1 (10cm)
  • Use Ctrl+A on all objects to make sure their scale value is set to 1

In your blend the size of the container receiving the fluid is simulated to be about 3mm. Make this bigger to get a better simulation - The longest dimension of your domain is the real-world size (m) in the domain settings. Make the domain just big enough to contain where you want the fluid and the real-world size to a realistic figure.

You will still get a gap but cgi is all about faking things. The size of containers do not have to stay the same after you have baked the fluids. You have to learn to get around the inherent limitations.

Richard

Hi,

You have two choices: Increase the resolution to about 1000, or make your domain much smaller. You are wasting a lot of space inside that domain. I’d estimate that more than 95% of its volume is empty!

I’ve downloaded your file. I changed a couple of things: I set the obstacle volume init to Volume, and I shrank your domain. Then I set the domain resolution to 100 and the results look fine to me.

Thank you. I have solved the problem using your suggestions, especially the one about ‘the size of the container does not have to stay the same after you have baked the fluids’.