Fluid Obstacle is Not Working?

Hello all, I have a VERY simple Blender scene, mainly meant for testing. It is where a blob of water falls into a box… Pretty simple. Now, the setup is like this:

  • Domain Box
  • Fluid Object (UV Sphere)
  • Fluid Obstacle

Pretty simple right? Well my problem is that when baking, I noticed that the fluid goies slightly through the obstacle. So I change the obstacle to shell instead. This kind of fixed my problem, and by kind of, I mean that now, it doesn’t actually touch the obstacle, it acts as if there is an invisible obstacle, exactly the same shape, but a little tiny bit smaller. So I tried both instead of shell, but that had the same results as shell. I have had the same problem with ALL of my fluid simulations, and I see these awesome Youtube videos of amazing looking, and flawless fluid simulations. Here are the things I tried:

  • Raising the Domain Resolution
  • Raising the Domain Subdivision, and Particles
  • Increasing the Size of the Whole Scene in Hopes of More Detail


P.S. Here is some links to some of the awesome videos I was talking about:

There will always be some gap, the higher the resolution the smaller the gap.

The object you use for the obstacle does not have to be the same object that you use in your render. Make the obstacle a slightly different size to take into account this gap.

That happened to me once and I think what had happened was that I had made an obstacle (champagne glass), created the fluid sim domain,etc, added the glass as an obstacle,and baked it. Then after baking a few times I added a subdivision surface to the champagne glass (and I think i applied it) and when I baked again there were issues with the obstacle boundary, but I have created a lot of really nice, convincing fluid sims since then so it’s definitely possible. Post your blend file.

Um, I may sound stupid for asking this, but how do I post Bledner files (I’m new around here)?