Fluid on Obstacle problem

I have this problem with fluids that seems to be scared of obstacles. It sort of “deforms” when touching an obstacle.

Here are some pictures to explain it better:

And here is my settings:

Fluid settings; /The water is subdivided as well, but the problem is the same with/without it subdivission

Obstacle Settings;


Try to increase final resolution. It’s simple but maybe can be that.

I guess what you are talking about is the “Resolution”? In that case; i have tried increasing it a lot, with no luck, and its already pretty high, as you might see :slight_smile:

There is a relationship between resolution, Real World Size and the actual scale of your meshes. A fluid simulator of this type can only simulate up to a 10 meter cube of fluid in Real World Size values. It can be of any size mesh, but the simulation itself will be treated as no more than that much equivalent real world liquid. However, at this size, you need a ridiculously high resolution to get accurate results. Even at extremely high resolutions it may still look bad if the mesh itself is quite large. Think of that resolution as a reflection of how much mesh geometry the fluid has to work with in the entire space of the domain, not just the visible quantity of fluid. If your resolution is not high enough, you just won’t have enough polygons to work with.

Remember that the default cube is 2 Blender Units on a side, which is in simulation terms 8 cubic meters of space. If whatever you’re working on is larger than the default cube, the simulation results are almost guaranteed to look bad. I don’t know how big your meshes are, but that is a common pitfall.

That said, your screenshot does not look like a very high resolution at all. You said you tried increasing it a lot. How much do you think is a lot? How big is this? What exactly are you trying to simulate? What are the rest of your fluid settings? That screenshot is not very informative.

Another common problem is unapplied object scales and rotations. If you are resizing things in object mode, you need to apply those transformations to the object with Ctrl-A before simulating, or you will get odd results. Otherwise the simulation will be running at one scale while your mesh appears to be at another.