fluid plateaus when interacting with obstacle


(mindbender) #1

I have this problem that I’ve been trying to fix for a few months on and off. I prefer to figure things out for myself but this one is stumping me. This first screenshot is to give you an idea of how the fluid works.


After the fluid stops I expect it to drip off, but I get these weird plateaus in the fluid on the head.


It ruins the effect. It would be passable if there was an air gap if it was smooth all over. The above is from the fluid sim baking at 400 res. I tried to bake it at 700, but I just get more fine plateaus. I can’t go beyond 700 resolution for the sim due to hardware constraints.

Does anyone have an idea what might be causing this? Unfortunately I can’t post the .blend file because it’s work-related.

Attachments



(mindbender) #2

bump… could really use some help to understand what’s going on here.


(Ovnuniarchos) #3

Without a file to examine, there is a ton of possible points of failure, so we can not know. Could you supply a file?


(Helmut S.) #4

In a recent experiment, I observed the same problem.
Had no time to investigate, but what I’d like to try is to run the simulation again with “eliminate air bubbles” option active (was disabled so far).

However in my scene this is only part of the problem. The other major bummer is that Blender’s fluid sim doesn’t really support animated obstacle meshes, so I wonder whether diving into research makes much sense.


(mindbender) #5

Oh, Blender doesn’t support animated obstacles? That could be the problem, I’ll try disabling animation during the key part of the fluid sim!


(Helmut S.) #6

It does, but fluids will always behave 100% sticky, no free slip. So you can’t really simulate water or other low-viscosity fluids, the fluid will always behave like kind of sticky jelly on the obstacle.
To prevent misunderstandings: “animated mesh” means, the mesh itself is deformed. Moving, rotating, scaling objects in animation will work with free, partial or no slip fluid settings without problem.


(mindbender) #7

I have been doing experiments off and on when I get time and I have a guess about why it’s settling in plateaus. Below is from a simple one, I set the domain to show only the wire frame in the viewport.


The fluid above has 100 resolution. If you look closely you can see the horizontal lines parallel to each other in the fluid. The fluid is built in these horizontal layers of fixed distance from each other, and triangles connect them.

Once I saw that I thought there’s probably no escaping the problem, so I tried a work around that works reasonably well. This first one has 200 resolution and has a similar problem as in my original post. You can see that the fluid is floating above the object and kind of pinches off at the edges.


This one below is at the same resolution, but I duplicated the obstacle, scaled it down slightly so it sits within the original, and removed the fluid obstacle settings from the original. In other words, the obstacle is not what you see, but a slightly smaller copy of the object that is hidden by the larger one.


You can see that the fluid appears to be hugging the object a lot better (in fact the fluid intersects the object). But it’s actually floating on top of the mini-obstacle underneath. As for reducing the line effect, lower resolution appears to be better, because the higher resolution tests I did seem to be really trying to make the lines more defined instead of getting rid of them.

I find it hard to believe this is normal for fluids and that there is no way to control this. But on the other hand most of the videos I’ve seen are of a fluid in a cup or other container, not rolling off the top of a smoothly curved object.

Anyway, thanks for the helpful comments. If someone finds a better solution please post it here.