fluid question

Hello
does anyone knows why?
the problem is that fluid leaks out of obstacle.
I have 3 things 1. Inflow 2. obstacle 3. domain
The obstacle is a cup which holds the fluid. At the base of cup it’s curved (it’s not square)
but as fluid is filling it it fills as square and it looks like it’s leaking out of cup.


this shows the domain box.

this shows the wire frame of the cup as you see the base is curved

this is how water is filled as square at the base
I baked it with final resolution of 150, viscosity water, domain boundary smoothing 1.3 and subdivision 1.

Apply the subsurf in the cup.

subsurf was already applied, the original cup had a square base, subsurf made it curvy. so it already has subsurf.
any other solutions? Anyone

Much too little supplied information to give any definitive answer.
Just attach your blend file rather than having other users going backwards and forwards guessing what your settings are.

I’ll attach the Blend file with a screenshot of leaking water out of cup.
(not sure how to attach the file try to see if attaching file using attach photo will work)
Thanks for your inputs
leakingcup.blend (391 KB)


Contrary to your earlier post you haven’t applied your subsurf modifier in your blend file.
Also for all objects clear their scale values with Ctrl+A / Scale and increase fluid resolution to get a more accurate simulation.

Attachments


Thanks, you are right.
The first time I pressed apply the window showing modifier disappeared. In my second try I did not press the apply and the modifier window stayed present. If we apply and the window for that modifier in this case subsurf disappear, how do we remember or know later on if we ever applied it or not?
Anyhow I did apply and the problem seems to be solved. I tried a resolution of 300 and it crashed after a few minutes. about 1.5 hour ago I started to bake it with a resolution of 150 which is almost 20% done.
Thank you