Fluid Sim Problem - At Hi Rez Still Falls Through Obstacles & Outflows (A Lot)

(Ghost_Train) #1

:eek:
OK. I watched that fluid sim video tutorial, searched and searched the forum and so on.
I’m sure the answer is somewhere, but I have not yet found it.

My main problem with this one is the fluid keeps falling through my obstacles…as
well as 2 outflow objects. Is it because they’re too thin? Are outflows supposed to
stay in square shapes to work or something?

I’ve heard you have to pump up the resolution when this
happens but it’s still doing it at 210. A lot. Not sure what my PC’s limits are so I
can trying higher rezes but I’m not so sure it’s going to do much.

If anyone can help me with this I will give you a hug, mentally. :wink: (I’m not gay though)
And I am still making changes and trying things. It just takes all day to bake/render.

Here are the current YouTube vids of what’s happening?:

http://www.youtube.com/watch?v=HmeMqeDWMH4
http://www.youtube.com/watch?v=r9-HAynACMU

Here are my latest failing settings.

Frames of animation: 200 at 30fps

Domain Transform Properties:
Geometry dimention: DimX: 60, DimY: 20, DimZ: 60

Domain settings:
Resolution: 210
End-time: 6.66
Graity: x:0, y:0, z:-9.81
Realworld-size: 4.0
Generate Particles: 1.5
Surface Subdiv: 2
Surface Smoothing: 2.5

Fluid settings:
Inflow
Init Volume
X:0.80
Y:-0.80
Z:-0.40

Bowl:
Obstacle
Init Volume - Free

Water Slide (Top Layer):
Obstacle
Init Volume - Free

Water slide (Middle Layer):
Outflow
Init Volume

Water slide (Bottom Layer):
Outflow
Init Volume

http://i34.photobucket.com/albums/d136/frostythestick/FluidSimProblem02.jpg

0 Likes

(Jason van Gumster) #2

For your obstacle… with something that thin, you have two options…

  1. play with making the obstacle init with shell rather than volume

  2. (and this is probably the better option), create another object to be your real obstacle that is thicker and use that for the obstacle calculations. However, when you render, swap back in the thinner obstacle.

0 Likes

(Lord of the Rings Junkie) #3

Yep, looks like your obstacle needs to be thicker. If that doesn’t help, try giving it a simple subsurf. (NOT catmull-clark.)

0 Likes

(Ghost_Train) #4

Awesomie! :spin: Ha. I used catmull-clark subdivide on
just about everything subdivided here. I haven’t gone back in to swith up the
subdiv yet to find out for myself, but what is the difference between catmull and simple?

Also, I didn’t know for sure if obstacle thickness played a part.

Thanks for sharing your input. I will go do this and come back with results.

0 Likes

(Lord of the Rings Junkie) #5

Think of a simple subsurf as a subdivide modifier. You get all the extra geometry, but it still looks exactly the same as the cage mesh.

[Edit] Example. The cube on the left had a catmull clark subsurf modifier applied, while the cube on the right had a simple subsurf applied.

Attachments


0 Likes

(Ghost_Train) #6

Cool. I did start to catch on when I started messing with it. Before this I did not notice
options with that modifier. I’m starting to learn.:smiley:

Also, I went back and mad the obstacle and outflow bigger while baking but fluid still
falls through. Maybe I need to make it rediculously huge. Like scale up 20 or 30.

current obstacle scale:
http://i34.photobucket.com/albums/d136/frostythestick/WaterExpE-Obstacle.jpg

current outflow scale:
http://i34.photobucket.com/albums/d136/frostythestick/WaterExpE-Outflow.jpg

I’m still confused at why this happens. Even with the outflow. Are these just a few
bugs that still remain in Blender’s fluid sim that we have to work around until they get
figured out?

0 Likes

(Ghost_Train) #7

Also, how are you guys attaching thumbnails to your posts instead of the actual
full sized pic. I feel back that I’m the one adding all these huge pictures. When I
hover the mouse over them it looks like they are hosted by blenderartists.org.

0 Likes

(Jason van Gumster) #8

First of all, it looks like your outflow shape and your obstacle are occupying the same physical space. This is likely to cause confusion to the simulator. What do you need an outflow there anyway? If the amount of fluid is too much, simply reduce the force or size of your inflow. You’re probably over-thinking on this part.

Also, while you’ve made the bottom of your obstacle thicker, the sides are still thin. Expand the obstacle laterally to account for this.

0 Likes

(Ghost_Train) #9

Well. At first there was only an obstacle with fluid falling through so I added the
outflow underneath it in hopes that it would solve my problem. Unorthodox/noobie
ways of doing things.

0 Likes

(Lord of the Rings Junkie) #10

Delete the outflow, and make sure there are no intersecting obstacles.

0 Likes

(Ghost_Train) #11

Will do.

For now the 3rd attempt is online. I’m so close to getting this thing conquered.
At least I hope so. I don’t think I could possibly be making progress this fast
without you guys here on the BlenderArtists forum. So the thanks goes to you.

0 Likes