Fluid Simulation Baking Strangely

It’s pretty simple: a cup that moves along the x axis with water in it. I thought it was simple, but Blender is doing some really wacky things. Here is what I did (I have the .blend file uploaded, too, so you can take a look):

  1. Add a cylinder as the cup and model it however you would want a cup to look. Add a solidify modifier and apply it (I tried not applying it and got the same result).

  2. Add a cube and add a subdivision surface of 6 iterations. Place it inside the cup, not touching any of the edges.

  3. Add another cube to act as the domain.

  4. Set the cylinder as an obstacle of type “shell.” Set the subdivided cube as a liquid of type “volume.”

  5. Animate the cylinder by moving it down the x-axis.

  6. In the fluid panel, click “Export Animation” for both the fluid and the obstacle.

  7. Finally, bake the animation.

You might get something different, but the rendered fluid is larger than the fluid I had put in and it sometimes ends up outside the cup. Even if I didn’t animate it, I’m sure I’d still have this problem. Any explaination? Thanks in advance.


fluid_problem.blend (1.93 MB)

i would start by increasing the resolution of your simulation. also, your fluid object doesnt need a whole bunch of subdivisions. blender only uses the fluid as a basic shape. increase the subdivisions of the simulation under the domain world tab (i think)

good luck :slight_smile: