Fluid simulation: how to avoid these strange artifacts

Dear All,
I have a strange artifact showing up in my fluid simulation (see image). In the video, it’s very disturbing. The only workaround for me was to use a container with 45° walls, not always ok obviously.
I tried to increase significantly the resolution of my simulation, but it didn’t help.

Probably it’s something very easy, I’m just starting to explore this new fluid-simulation world.

Thank you in advance!!!



Attachments

laghetto.blend (566 KB)

the way the fluid sim works is basically begging for this to happen, because of the gridlike nature of the system artifacts such as this are unavoidable, all we can REALLY do is botch - up a workaround…

try making 2 versions of the collision object, we’ll call them a and b …
only allow A to actually affect fluid system collision
B will be a dummy… now for A,first make it an invisible material…l. no shadows, no shading, nothing… inset the verts in edit mode to make this one slightly smaller than B… now the difference between the “collision faces” and the “visible faces” should hide the stepped effect… the only issue for this workaround, is the material that B is using (the sides of the cup, bowl, or container), would make the workaround useless if it is glass, ice, or anything “transparent”, meaning you would still see the stepping through the material…

the only surefire way, to completely avoid this issues with no “hacky” workarounds, would be to use an insanely high resolution for the fluid domain and then use the fluid systems subdivisions and smoothing options to get it right… then wait 4 months to bake the crazy high rez simulation LOL… theres a reason people use hacky workarounds after all

If you plan on rendering only one image you could apply the fluid sim in the modifier stacker, then go to the sculpt mode and use the smooth brush to smooth out the steps.