Fluid simulation not at all following like the tutorial(S)

I’ve watched several tutorials about fluid simulation. Some of them go into it more than others, but they all start with the basics of domain, fluid, etc. So I go and try the most simple possible fluid setup you can possibly do, and it doesn’t look anything like the tutorials. I am using Blender 2.74, cycles rendering. I have not changed ONE SINGLE THING form the default startup file from a clean install. Only thing I did was select “Cycles” instead of “Blender” as the render engine. So, following the tutorials, I get the default cube, rename it “domain” and scale it in the Z axis. Still in “Object” mode I add another cube, name it “fluid” and scale it down a little and drag it up near the top of the domain cube. It is completely contained within the domain. Then I bake it. When I play it back, I get blocks that fall slowly and stay separated. But in the tutorials, it looks more like real fluid, and it “stays together” as a steady stream of water, not individual “pieces” of water. I tried to subdivide but there was no difference. And, if the tutorials used any subdivision, they don’t tell you that when you watch it (and they should). I know that Blender can create amazing water and other fluid simulations, so why doesn’t it happen all the time? Again, I start Blender from a clean install of 2.74, and the ONLY change I make is to select Cycles instead of Blender for my render engine. So please don’t ask me to check this setting or that setting, unless default settings in Blender (as installed) would cause fluids to look the way I said.

It would be helpful if you posted the link to the tutorial and the .blend file that you created. Without it, any possible suggestions are just blind shots in the dark. Also, you said you changed the render engine to Cycles. Have you tried the tutorial without doing that to see if it behaves differently?

With default setting, i get that. Is it what you were talking about ?


You can increase the flow of water by setting the inflow mesh like that for instance.


I don’t know that much about fluid simulation but the scale is important. The basic cube is 2 Blender unit wide (if you set Blender to use metric, it’s 2 meters). The exact size influences the time it takes for the water to fall (is it 10cm or 10 meters ?). But in addition, there’s a parameter in the domain that specifies the duration in seconds of the simulation and it doesn’t match the frame rate necessarily…


If i understand it well, here it means the baking will cover 4 seconds. The default duration of the baking is 250 frames (with a brand new untouched Blender). The default frame rate is - i believe - 25 frames per second that is to say 10 seconds. So by default, the simulation is slowed down a lot.

To sum it up, you’re right, the default settings seem to give a blocky simulation. To correct it, try increasing the resolution of the domain. changing the size of your objects, playing with the duration of the bake. Enjoy !

I get the default cube, rename it “domain” and scale it in the Z axis. Still in “Object” mode I add another cube, name it “fluid” and scale it down a little and drag it up near the top of the domain cube.
Ensure you didn’t scale the domain in object mode. If so you will have to apply the scale with Ctrl+A before baking the fluid sim. Make the domain only as large as it needs to be to make best use of the resolution

For a simple test, with the default cube selected you can set up a quick fluid sim. Set the viewport display to Final and increase the resolution


Cycles and Blender Render are renderers, they have zero effect on the fluid simulation

The tutorial was also using cycles. I will try to find it again. Otherwise, the .blend file is simple, just a domain cube and a fluid cube, just as simple as possible. No settings were changed, so it should be easy to duplicate.

Richard, that is more or less what I see, although mine looks even blockier. I will try your suggestions. Thanks.

Hi guys! I have a problem with fluid particles.
I made 3 fluid simulation with particles and i used the option offset (in domain settings) to make them started at different time. But the particles start ever from frame 0, someone know a way to fix it?
Thanks