Fluid Simulation problem

Hello i have a problem with the fluid simulation. I would like some water to run down an leave. But the fluid always runs down in steps, as you can see on the screenshots below. What are the right settings?




Make sure the the display for the fluid in the 3d viewport is set to Final and not Preview. If you are using the default settings, the fluid resolution will be way too low. As there are so many variables that can affect the fluid simulation it is advisable for you to put a link to your blend fle. You can attach your blend file to your post or host the blend file at http://www.pasteall.org/blend/

Richard

Ok here is the blend. file. The viewport display is already set to final.:(. But then what could be the problem is it the resolution?
fluid simulation.blend (407 KB)

I just tried out your BLEND file and it sucked me in for over an hour. That is the thing with the fluid simulator. We all believe that if we just spend time and change values, that it will actually work. But I found that to be the contrary almost every time.

I went ahead and removed the leaf from the simulation and replaced it with a plane. Even with a plane, the fluid will not smoothly roll down the surface. It just blobs and chunks along. I had the resolution set as high as 150. And yes, I tried slip, no slip, various viscosities, timing, domain size etc…

Thanks a lot for your effort i also tried it with a higher resolution (170), but the fluid still looks realy strange:(. Does someone else got any ideas?

have you changed the slip tye to free on the leaf?
if that fails, try to mess with the real world size.
if that agin fails, maybe your drop needs more velocity?

And yes, I tried slip, no slip, various viscosities, timing, domain size etc…

Just post a working scene, we all have spent time on it.

Ok. But then how could i animate a water drop running down a leaf?

I have checked your fluid sim blend file. If you click on the domain boundary box and changes the value in Physics --> Fluid --> Domain Boundary --> Surface --> Smoothing from 2 to 5 and changes the value of Subdivisions from 2 to 0 you will get a nice result without steps.






Thanks a lot it worked!! Thanks :smiley:

I would hardly call that a “solved”. The fluid jitters all over the place with those settings.

Atom yes you are right ): The fluid still acts strange and i also get some weird distortion):. But at least the step problem is solved. Now Does someone got any ideas about the distortion?

I still need help any ideas anyone?

Change real world size, the higher the number on your real world size the (generally) better it seems to get…Personally I am having my own problems with the Fluid sim right now…

Still didnt work ):. There are still these strange distortions.

I need help! Any Ideas anyone?

First, try no slip.
Second, How big is your domain? Because it would be heavily advantagious if you make a new domain, delete the old one. And make it a whole lot smaller. Make it so that the liquid is only JUST “Realistically” contained.
Third, Really Blender Fluids are fairly bad…the thinner a fluid goes the worse it gets. Try making more water go down the leaf, and it will be less thinly spread over the surface.

Again, I really need to get back to my own problem with the Fluid sim…So…little…RAM…Left…