Fluid simulation problem


I’m getting some strange behaviour when using the fluid simulation, I’ve probably not enabled the right feature but after many hours of trying I can’t find what I’m doing wrong so any help that can be given would be greatly appreciated. I’ve created this test file to illustrate the problem I’m getting rather than the original file that runs a simulation for much longer to make things easier.

The problem I have is that fluid that is meant to be sticking to a moving obstacle is dissolving or behaving in unusual ways when the direction of movement of the obstacle is changed.

In the file below I’ve got a cylinder on a stick set to No Slip being dunked into some viscous fluid. When it is pulled out of the fluid the fluid is sticking to the top of the cylinder, however when the cylinder starts to go down again to be dunked again the fluid on top of the cylinder dissolves, then reappears then disappears again before it is dunked again. It isn’t simply just a case that the fluid is running off the obstacle as it happens even if the top of the cylinder is concave like a spoon.

As I’m a new user I don’t think I can post a link but I have uploaded a YouTube video to show the problem with the frames that the issue appears in slow motion for which I have included the link in the text editor panel in the blender file attached so the issue can be viewed without having to wait through a lengthy bake. In the file the simulation is set to a resolution of 200 however when I’ve tried simulations at resolutions of 500 the problem still persists so I don’t think it is an issue of resolution.

Thanks in advance for any help that can be given.


Fluid Simulation Issue.blend (603 KB)

Some general comments about the blend file
Very Important, ALL objects should have a scale of 1 for each of their axis. Your objects haves scales all over the place (look in the properties panel, shortcut N to see). Select all objects and use Ctrl+A to apply both scale and rotation before you bake the fluid sim. Also the domain object needs to be as small as it needs to be to ensure you make use of every bit of fluid resolution. Make the domain a cube only as big as it really needs to be to encompass the fluid simulation, yours can be made smaller (ensure you then apply the scale as mentioned previously). Also make the domain resolution as big as you can (200 is not huge) and if you don’t use the preview option, don’t waste baking time by making the preview resolution bigger then you need.

Hi Richard,

Thanks for the reply. I have created a new version of the file, with a cylinder emerging from the fluid then dropping back down to cut out frames that don’t illustrate anything, with the scales all set to 1 and the resolution now set to 300. However it appears that the problem of the fluid disappearing from the obstacle when it changes direction remains.

I have attached the new version of the file with another link to a YouTube video showing the result from the render of this file.

I had previously been trying the resolution of the simulation at 500 but after trying at least 10 different bakes with different values and settings to no success I dropped it down to 200 until I could see any change in the problem at that resolution. Was 500 too low a resolution to be running it at?


Fluid Simulation Issue New.blend (592 KB)

Nobody got any ideas how to solve this problem? I can’t believe that this is beyond the capabilities of Blender’s fluid simulator but I’ve tried all manner of things including adding a fluid control object but nothing seems to work? Am I missing something or is it not possible in Blender or is it a glitch?

Thanks in advance for any help.