Fluid simulation too 'sticky' and water looks like blobs


I have made a fluid simulation with water presets but for some reason, the mesh is too thick and the water looks like big blobs…

Any idea if it is related to a simulation parameter?


Your resolution is very low
You have set the viewport display to show the Preview fluid resolution which will not be as good as the final resolution being used for the render
Ensure you have applied scale of all objects (Ctrl+A)
Ensure the fluid domain object is no larger than it needs to be. If you make it too big you are spreading your resolution over a larger volume leading to more blocky fluid
Ensure the fluid world setting is a realistic size (in metres)

1 Like

Hello Richard Marklew,

It all was done, except for the resolution (I guess you are talking about the final resolution)…
I mean, that is a render, the resolution is 120 and it took around 1 hour to bake…

Resolution of 120 is not that high, especially is you want fine water.

You should not expect stellar results from the fluid simulation and especially without long bake times

Thanks for the quick answers.

May I ask you how would you do what I am trying to without using a fluid simulation?


You could look at particles and use motion blur and fake the appearance of flowing water
Or increase the resolution and leave your computer to bake while you go and do something more useful

Will try that option out! thanks

If you’re going to use particles as Richard said, I think you should check the Molecular addon and the Cubesurfer addon, both made by Pyroevil.

Thanks alot julperado!

Will check them out

In the fluid boundary panel, there is a value labeled ‘subdivisions’, perhaps you can turn it to 2 or 3 as it produced a much higher quality simulation back when it was first committed in the 2.4x days (it should be more or less the same as the simulator has not seen a whole lot of development since).

Hi, did you find a way to get better results or did your fluid sim remain sticky and blobby?