Fluid simulator problems

I’ve been playing around with the new fluid simulator for weeks now and although I’m very impressed, I can’t help but notice that the whole fluid object is actually sorta offseted? Look at the pics below and you’ll see what I mean. It looks like the fluid simulator is a little inaccurate, but I think that is way too lousy for a resolution of 128!


One more problem is that I can’t resume rendering my baked results. :o Say I have a 250 frame-long fluid animation and I stopped rendering halfway at 125, when I tell Blender to continue rendering from 125 and press Anim, the whole fluid simulation only begins at frame 125.

So now, I’m forced so sit by my computer to manually render and save each frame until this animation is finished! Can someone please help me end my torment?

EDIT: Just saw that somebody else baked his/her fluids with a resolution of 512 (!). Maybe mine just isn’t high enough even though it’s already killing my comp the way it is now. I remember that the CVS builds of Blender 2.4 had a limit of 149, but I’m guessing there’s no limit now (other than practically). All I have in my scene is a 10X10X10 domain and nine 2X2X2 cubes as obstacles at the bottom. The fluidsim starts with a 8X8X2 chunk of fluid near the top of the domain. What resolution would you guys recommend?

I use 200 res and so far Im happy with the quality of it, but if u think of a quality of big scene where a tunami like event, u have to wait, for what, I have learned that it’s only ativable with res of 1000 or more, so for me hehe 200 is enough, like to make a glass of vine think thats the only thing thats looks good in blender for now

Yeap, the problem is an inadequate resolution. I tried simulating it again, this time with a dreadful resolution of 64. The liquid actually passed through the top half of the cube before it detected an obstacle and splashed away.

So I re-simulated it with a 200 resolution, streching my computer to its limits. The problem is still noticeable, but better than the pics in my first post. If I wanted to render these results, all I have to do is slightly adjust the cube dimensions (no one will notice :wink: ) so that it doesn’t touch the liquid, and press Anim!

How about resuming an interrupted render, though? I still can’t find a solution other than manual rendering and saving.

Can you render as JPEGs and then put them all in a folder, that way you can stop whenever, and lose nothing!

Then, when it’s all done, just put all the frames together in a program like Animation Workshop. That’s what I always do.

P.S. Animation Workshop comes with Paint Shop Pro, you can get it cheap on ebay!

No it doesn’t matter. Even if your rendering jpegs, the fluid sim restarts whenever you render after frame 1.

I always render in jpeg/targa when it comes to animations, but that’s not the point. The time when the baked fluids begin replaying are actually determined by the Sta: parameter, which is a major headache for fluid simulations.

To resume an interrupted animation render (using jpegs), it would make sense to adjust the Sta: parameter to tell Blender to continue rendering from wherever it was interrupted. But this is not true for fluid simulations because the fluidsim will restart from that frame.

The only way around it is to manually go to the last rendered frame in the 3D window, render and save the jpeg by hand. It’s frustrating.

P.S. Saxofoner91 did you know that you can roll all your jpegs into a video file using nothing but Blender?

Shouldn’t baking the fluid animation work?

That just saves all the information to each frame as far as I know. It shouldn’t change the data in the frames if you decide to pause your animation and then restart it in the middle later on.

I always bake my fluid animations before rendering them. It saves time in the long run because you can see any errors that crop up without having to render them.

btw just tried a 256 resolution. Left my computer thinking for 5 minutes and came back to see it still thinking about frame 1 so I tried escaping then had to kill the process manually. Ouch. Maybe 200 will work though.

sigh Here’s what happened.

I set up a fluidsim scene. Simulate and bake it for 250 frames and then stop. Looks good. Sets Sta: to 1 and End: to 250 so that Blender renders frame 1 until 250. Starts rendering the animation in Jpeg images. Reaches frame 125. Everything still looks good. Thunderstorm comes, so I cancel render, save project, and turn off the computer to continue some other day.

Turns on computer. Opens Blender. Browses through the baked results in 3D window. Still looks good. Sets Sta: to 126 and End: to 250 so that Blender renders frame 126 until 250.

Weird stuff happens in 3D window. Frames 1 to 125 appear to have no fluid mesh data. Baked simulation only begins replaying at frame 126 and ends at 375. Tries to render. Rendering is exactly as depicted by the 3D windows. Feels frustrated.

Sets Sta: back to 1. Everything goes back to normal. But Blender can’t automatically continue rendering from frame 126. The only solution: Go to frame 126 in the 3D window. Press RENDER. Wait. Then save Jpeg image as “0126.jpg”. Repeat for frame 127. Repeat for frame 128. Repeat for frame 129. And so on and so forth.

This is about a clear as I am ever going to make it. Any help (whether has been offered, is being offered, or will be offered) is much appreciated.

sigh %|

i thought you had to do the whole thing and then use the blender sequencer

question if you use a res of 200 are you getting a needed bake size of 2 G

thats what i see when increase it from 50

yu_wang, maybe you’ve overwritten your previously baked data.
Set a new path for each fluid test.