Fluids don't cooperate well with things that have subsurfaces on!

I’ve been playing around with fluid simulations, and it seems that when I set an object with subsurf on as an obstacle, when the water collides with it, it reacts as if the obstacle didn’t have subsurf on, as if the vertices were in their original places…

Make sure that the “fluidsim” modifier on your obstacle is lowest in the stack, beneath your subsurf modifier.

Thanks, I’ll try it out.

And it doesn’t work. Yay.

Yay…
can’t you apply it?

Nevermind.

I got it to work by going into the obstacle settings and setting the boundary type from “volume” to “shell”. Wow. I’m an idiot.