Following a Bezier Curve

Hi Blenderpeople,
i made a few cubes follow some bezier-curves, but I can’t find how long the animation is and when it begins. there is no lpo-curve for anything(at least I can’t see anything in the lpo curve editor no matter which object I select and no matter what lpo type I select in the lpo curve window).

All curves last 300 frames, but some need to start at frame 200 and some others need to begin at frame 205. What can I do to change that ? In the scene -> Render buttons I can only change what part of the animation is seen in the final animation but nothing I would like to change. The scene->anim/playback buttons do exactly the same and they change the settings in the former mentioned window(and the other way around).

The DupliStar and Dupliend settings in the objectbuttons seem to do nothing. I searched anywhere, I don’t know what to do.

Please help me

You change the speed IPO of the curve manually. I don’t like this idea in Blender because it means that the curve itself defines the speed of all the objects along it. Then you have to override this value for each object using the time IPO.

So you basically select the curve and choose the path option in the menu at the top of the IPO window. Then the item speed appears. Ctrl-click to add a key. The curve goes from 0 to 1 so say you want the objects to start moving at frame 50 then you would set a key at x=50, y=0. If you want them to stop at frame 100, you set a key to x=100, y=1.

You can adjust the curves to make the items go backwards too.

Now, if you happen to have more than one object attached to a curve, you can make then travel at different speeds with the time IPO. So select an object and choose the object option in the IPO menu. Then choose the time value. If you want the object to start moving at frame 100 as opposed to 50, set a key to x=100, y=50. If you want it to stop at 300 instead of 100, set another key to x=300, y=100.

This system does make it easier to animate lots of objects along a curve at the same speed but it’s not immediately intuitive. The main problem I have with curve paths is the fact they are measured from start to end. So if you edit the curve, all the keyframes get messed up. I think it would be nice to have a feature where if you have an object attached to a path, you just set when it starts and ends and the keyframes stay at the same position on the curve no matter how you edit it. Maybe the keys can use the path length from the nearest CV. Then if another CV is added closer, this path distance is updated.

Another feature would be to show the curve times per object when an object is selected. So you’d choose an object attached to a path and the path would then show the start and end times for that object. If multiple items are selected, only the first item Blender reaches would be shown.

Thank you very much for that tip. I think I know what you mean but I must have done something wrong. I selected one of the curves and added an lpo curve with 2 key frames: x:0, y:0 and x:200, y:1 (with path selected)…
But now the object on the curve does not do the whole curve in 200 frames, but it has become slower and does a bit more than half the curve (I guess 2/3, that could be it and I guess because the original was 300 frames and I said 200 in the lpo-curve) in 300 frames.

Do you know what I have done wrong and could help me ?

Did you add a time IPO to the object? If you did, delete it and it will move based on the curve’s speed IPO. That’s the only thing I can think that would slow the object down.

The frames of the curve path itself in the edit panel doesn’t matter as the speed ipo overrides it. So you choosing 300 wouldn’t make the objects fall short.

No, the none of the objects have any lpo curves. And I added the new lpo speed curve only to one curve.

But I found one thing which I think is kind of strange but explains why the curve with the lpo-curve isn’t done completely by the cube: The path length in the editing buttons under curve and surface of all bezier curves say 100 but all the boxes need 300 frames to do the curve. I think this has something to do with the global setting of the animation being set to 300 when the curves and the cubes were created (I can’t find any other option being set to 300, maybe someone knows and would tell me ?). But I don’t know how to change that. The duration of the whole animation (the duration of the cubes running the curves) changes when I change the path length but 100 is not standing for 100 frames but for 300 frames… very strange thing I think…

I also think I got the problem with the lpo curve but I don’t know how to correct that. When I look at the animation (with alt+a or alt+shift+a), I had a look at the green line running in the lpo-curve window… And I can’t understand what I saw !!! The green line only went to x 103 and after that it started again from the beginning ! The global animation length is set from frame 1 to 310. When the animation runs, the mouse pointer gets black with white cyphers on it. 2 on the bottom and one cypher above. I think all three cyphers together should tell the number of the frame currently seen (please correct me if I’m wrong). And this number runs from 1 to 310.

So my main problem is why there are three different scales for the frames:

  1. the setting which I can’t find anywhere telling all boxes where the boxes and the curves have no lpo curves to do the curve in 300 frames,
  2. the path length which thinks 100 frames are 300 frames, and
  3. the lpo curve which only goes to x 103 when the animation says frame 310 ( the animation of all boxes but the one with the lpo curve set to 200 ends at about frame 100, so it could be the same as 2)
    ?

Thanks for reading and caring about my problem :slight_smile: Does anybody know an option which could evoke that described problem so that I can correct it ? I would love to have all the settings which change any duration in the unit of frames (and as osxrules described it that’s how it should be so I can’t understand why it doesn’t work for me :frowning: )

FOUND IT !!!

In the scene are the render/anim buttons and there are two values: “Map old” and “Map new” the Map old here said 100 and the map new said 300. So 100 frames represented 300 frames.

If I change both settings to the same value no matter what value, this problem is solved :slight_smile:

Just wrote this for anybody who would like to know or got the same problem.

Happy blendering to anybody out there :slight_smile:

Ah, I forgot about those remap buttons. I also thought they only remapped once but maybe they’ve changed. Glad to hear you got it worked out.

I think those anim buttons should be moved to the main animation panel.