Following Building Blender Docs - get error - see video

I commented before to Campbell about this not working, but didn’t get a response.
Seems to be some error following the cmake directions via the terminal in the wiki.
Here’s a vid of the error I get.
I can build by opening the Cmake app and going from there, but if someone is following the directions
for running Cmake via the terminal they might get stuck.

Not sure if it was same person in IRC, but this did come up before and thought you got a response.

The command “cmake” will need to be in your $PATH. Im not sure what are the conventions on OSX, but on a typical unix system (Linux/BSD’s), installing CMake means you can run it at the command line.

Note that I never tested this on OSX and OSX build instructions don’t reference it:

… though from the looks of it running directly “cmake” should work.

Wasn’t me.
Anyway, seems setting CMake in the path is pretty convoluted
I’m not going to spend any more time on it, I’m just going to run CMake from the Finder.
Maybe the wiki needs to just mention that CMake has to be in $PATH and let them take it from there if they want.
Thanks Campbell.

We should really have working wiki docs for building Blender on all supported platforms.

If you don’t want to resolve - thats fine, but this means someone else will likely run into the same problem :S

So if any experienced OSX users can clear this up, it would be good.

I see you’re point.
I’ll work on it a few more days, but if anyone else already knows, jump in.

Looks as you run into the old bug cmd-line-links not properly installed.
Do following: open the cmake bin inside app-bundle (/Applications/CMake\\ <version> )
as with sudo, then from “Tools” menu choose “install for commandline use”

Thats it …

You can recheck: there now should be symlinks in /usr/bin for cmake, cmake-gui and cmakexbuild.


Not sure what you mean. Do this from Terminal? I’m not that up on Terminal commands, can you be more specific?
If you mean from the finder, I see this:

So I found I could add the bin from Cmake to the $PATH in the terminal via:
But cmake is still ‘command not found’.