Force GPU rendering for Render Farm?

Hello everyone!!

So, I’m on vacation for the next 2 weeks with nothing but a shitty laptop. It’s enough to work with blender, but not for rendering. Since I have an unlimited plan at a render farm (Lion Render), that shouldn’t be a problem.

Now, the farm supports GPU rendering. But my Laptop doesn’t. I also can’t change the computing device after uploading it to the farm, so I have to do that on a laptop without CUDA support.

Any ideas?

You could try this script on stackexchange

Both scripts don’t seem to work unfortunately :confused:

You can try this.

In your blend file change to a text editor
click new

paste this in:


import bpy


bpy.data.scenes["Scene"].cycles.device = 'GPU'

in the little browse text textfield, name it gpu.py
check the checkbox ‘register’ this forces the little script to be run when blender is opened.
In your user prefs you should make sure ‘auto run python’ is enabled
save the main blend file

try uploading to farm. I have no idea if it will work.