Forester2blend


(Brian J) #1

I hope somebody here can help me out with this.

I am using Forester2blend to place ojects in Blender based on the Forester object export text file. After selecting the object and pressing alt-p as the tutorial says, Blender makes one copy of the selected mesh at 0,0,0 and then I get the following error in the console:

PYTHON SCRIPT ERROR:
Traceback <most recent call last>:
File “Forester2Blend”, line 195, in ?
TypeError: attribute-less object <assign or del>

I have renamed my objects per the tutorial and retraced my steps several times. I have even created new files with Forester and still get the same result. I am using Blender 2.23.

Thanks for any help you can give!
Brian J


(Brian J) #2

Well I think I got it figured out.

I renamed the objects according to the tutorial:

“ME:tree, OB:tree”

As I understood it, I only renamed the objects I was using the script with.

After running the script the new object placed at 0,0,0 is named “ME:tree.001 OB:Mesh” Then I get the error in my first post.

So based on that, following meshes will be named “ME:tree.xxx, OB:Mesh.xxx”.

The problem comes in when ANY other objects have the mesh data block named “Mesh(.xxx)”. So I had to change ALL the object/mesh names and then save/load the file to clear unused data blocks. After doing that I was able to run the script ONE time. If I tried it again all the previous Objects created by the script with “OB:Mesh.xxx” would cause the script error. According to the tutorial you should be able to do one mesh after another, untill you’re done. I had to run the script in seperate files for each object to prevent the “OB:Mesh.xxx” name issue. Then merge them into one file.

What a pain, am I doing something wrong? Is there something that can be changed in the script so the object names will be assigned “OB:tree”. “OB:tree.001” rather than changing it to “OB:Mesh” ?

Thanks for any help you can give!
Brian J