FPS loss and crash failure, how do I fix it?

I used some methods to optimize my game, such as:
Override Culling ( main camera )
Occluder ( clone of the object forming to the walls )
Lod Bias ( most textures )
And just those, are there other ways to optimize a game?

I’m using a Rigid body collision because the Character collision gets a lot worse.
I set the X, Y, and Z options in Lock Rotation so that they do not rotate.
How do I fix this collision so as not to cross walls?

That’s not Physic’s lag.
It’s Graphic’s lag.

I see your using Specular Shaders & Ambient Occlusion Filters :thinking:
Those drain a lot of process power both for CPU & GPU.

Try disabling Extra Textures in -
Properties Window --> Shading(GLSL) --> Extra Textures
Also turn off any 2D filters.

Then see how much Frame-Rate you get.


Try disabling Bloom & SSAO filters to see if you get better performance.

but I already disabled

1 Like

My bad :slight_smile:

Try disability every option in -
Properties Window (Render) --> Shading (GLSL)
Either Lights, Shadows, or Shaders is draining your performance, we need to find out which.


ok

1 Like