Frame Node not working?

I’m trying to organize my nodes using the frame node but I cant add nodes into a frame!
I tried different keys like G,ALT-p,Ctrl-P etc. is this a bug in Blender 2.68a?

Can’t you just drag nodes into the frame ?

Dragging does not work for the frame node. I’ve tried different presets keys like maya, 3dMax but same problem. :spin:


Disable the Shrink option for the frame. You will then be able to resize it and it will accept the nodes you drop on it.

Dragging the nodes onto the frame works for me, just remember that your mouse has to finish up OVER the frame for it to take effect.

Thanks but Shrink has no affect on the node. I tried opening new instances of Blender but the frame node seems broken every time.
Maybe the next release of Blender might fix the issue.

Works here too.


Well it most likely won’t if the problem is at your end and you’re not doing anything about it.
Did you get blender directly from blender.org? What operating system? Have you tried the development version from http://builder.blender.org/download/ ? Did you check if others have had the same problem by searching from bug tracker/forum/google ?

I did that last one. It’s not a bug unless you have a configuration where blender doesn’t work right, in which case you would have to report it to get it fixed or fix it yourself.

Frame works properly in every build of Blender I have from 2.68a on, and as I recall for a couple of versions before. What is your version and platform?
I wonder if you understand that you can resize the frame by dragging the edges of the frame? No offense intended but sometimes these little things are the ones that we don’t try…

JA12-
The issue could be from my end, that’s why I maid this post for help. I Googled and Youtubed the subject of Frame node but
nothing relates to my issue.

I’m using the current build of Blender 2.68a and I’m using Windows7. When I look at someone’s .blend files, I can see some Frames used to organize other nodes but they don’t work if I attempt to add extra stuff to it.

I hope you are not confusing frames with groups. Have you ever used frames before and they have now stopped working, or are you trying to use them for the first time? Frames are there only to help you organize and have no other function.

You can’t just draw the frame and expect the nodes above it to be automatically placed in it. Maybe that’s the problem. You draw the frame, shape it to the right size, select all the nodes you want to be in it and then G key drag them just a little and they will be in the frame if they were over it.
But if you just draw the frame, even if the borders look like they are enclosing the nodes the nodes are not actually in it. You have to move them. You have successfully added the nodes when their drop shadows disappear.

These nodes have been selected but are floating above the frame that has been drawn below them, they are not yet in the frame.

These nodes have been dragged with G just a little bit; as soon as you click left mouse to accept the drag they became part of the frame.

If you accidentally select the frame as well before you drag, the frame will move with the nodes and they will not be added to the frame!

DruBan-
Wow thanks for the explanation! I’m new to Blender and no I never had the chance to use Frames.
Like I mention above, I’ve tried G, ALT P, Ctrl P etc. - when press the G key the node (any node) shoots off into a random direction. I switched to different hotkey configurations but same issue.

Sounds like a problem with your hardware. Are you using a standard mouse, or a tablet? Go to preferences >input and try unchecking continuous grab if you have it checked. I am surprised that you are able to model at all if your cursor is shooting around, and if this is only in the node editor I am at a loss too. You should install a clean copy of Blender, which means that you should remove the Blender folder in users >appdata before downloading a new installer. Also try not have more than one input device plugged in at the same time like a tablet and a mouse.