Framerate - please enlighten me

I was just playing around with the latest SVN build, pushed ‘p’ and my revolving monkey head looked like it was juddering a little as if about 15 fps. Checked the frame rate and it was 60. tried the framerate in the gamesettings and made no difference, I guess thats only for BlenderPlayer.
Anyway, tried ‘enable all frames’, the frame rate went up to 75fps and there as no juddering, smooth as silk. Can anyone enlighten me on whether this is a bug or am I using it wrong.

Also does the same on 246

Did you use the buffer shadow? Did you apply any blender material?

It doesn’t matter whether there’s no matierial, Blender Materials, Shadowbuffer. With ‘Enable All Frames’ checked its super smooth motion and with it unchecked it looks juddery and not smooth.
Have now tested on 245 and its the same so it probably always was this way.
I understand the ‘Enable All Frames’ was an option because usually blender would run slower than 60Hz and so usually you would want it to drop frames to keep up to speed.
It looks like now I’ll be switching ‘Enable All Frames’ on as the results look so much better.