Freaky Yafray Render!!!

This is what happened when I used the St Peter’s HDR probe and full GI in Yafray on one of my projects, keep in mind that the controller, plane, and console shell do NOT have raymirror qualities:

So how on Earth did that happen?! Anybody got a clue?

Aren’t those images used for lighting? looks like light streaming down from a stained glass window to me.

Hard to judge from that small render and especially the small informations…

a) Try increasing the filter value in the image loading tab.
b) Are you working with Photons? I doubt it but if so increase the number of photons used and / or play around with the radius (increase it).
c) If that doesn’t do it, please provide more infos.

When Full Gi is used, the HDRI background is not actually able to shot photons, so you can just use the Skydome method (if the HDRI background is the only light source in your scene).

Besides that, it could be a filtering issue:

You’re haven’t got the “tune photon” button turned on have you?

No, I don’t have tune photons activated. I think the issue is just the prefiltering. Anyways, I was using the cache option, and without the cache the effect doesn’t show up. So I don’t think this’ll be a problem.

EDIT: Yep, it’s the filter. As soon as I increase the filter even the slightest above one, the problem resolves completely, as far as I can tell.