Freestyle doesn't draw lines on material boundaries

I want to use the Freestyle “Material Boundary” feature, which essentially draws a line inbetween materials. I’ve got two materials set up on my mesh (although I really only needed one) which both utilize the same texture (I tried removing the texture for testing purposes, it doesn’t really solve the issue). The freestyle lineset-settings are mostly the default ones, I just removed all lines except for “External Contour” and “Material Boundary” (since those are the ones I want :P) and increased line thickness to “4”.

Here’s a screenshot of the setup:

Try deleting your line set and starting over. I’m not sure yet if the code is buggy or if I’m missing something in the logical order. I’ve been having similar problems.

See those whitish patches of quads? looks like there might be an extra geometry or reversed normal problem. But not always. You could try removing doubles and recalculating normal and see if that does it. Freestyle uses normals a lot.

@RamboBaby | Tried it, doesn’t seem to work.

@DruBan | The white patches come from a mirror modifier (I’m not sure why Blender displays it like that). There are no “overlaying” faces or reversed normals (I made sure to test everything with applied modifiers as well). Unfortunately Freestyle still didn’t want to render lines inbetween materials.

The issue does seem to be specific to this scene though, since it works fine with new scenes.

Thanks for the suggestions though :slight_smile:

Sometimes it’s just easier to save the file and append the scene to a new blend file. This solves problems in an awful lot of scenarios.