Freestyle rendering by collection include/exclude, not working

I have tried with 2.81 and the latest 2.83 LTS
Freestyle rendering by collection include/exclude is ignored

A related bug report is in the Developers’ forum and was marked “Solved”, but I can’t get it to work.

As explained by Philipp Oeser, you need to enable a meaningful edge type in blend file attached to bug report or to disable selection by edge types.
Here, it works with blend file of bugreport in 2.83 under linux.

Novelty of 2.83 is that Freestyle can be rendered as a separated Render Pass.
That means that Freestyle lines are not displayed into Combined pass in Render’s Window but only in a pass called “Freestyle”.
If it is what you are testing, that may be source of confusion.

True, but you still could get the same functionality in 2.81a, meaning the separation of the freestyle information, by defining a separate render layer where only freestyle renders.
Below is a screenshot of just that from the compositor, in effect you still get both separated with one “hit” of the render button

Thanks for participating, I have read that thread

Oeser has several posts, many of which are contradicted by others. Which of his posts is an answer please?
I’m not sure what are “meaningful edge types”. I’m pretty sure I have used a meaningful combination of edge types and collection and I have tried only collections (including in some tests and excluding in others). In all cases, whatever the collection settings had no effect.

I’m downloading that file now

I am talking about its first comment where he said that he enabled Silhouette edge type.
In demo.blend file of bugreport, only edge type selected is Border.

But Border means the border of a hole in mesh surface.
If your scene is made of perfectly closed cubes without holes, and you only ask Freestyle to render borders of holes : it is a pertinent result if Freestyle renders no line at all.

Thanks, I understand what you are saying, but I have made meaningful and educated selections, based on the manual, of the freestyle types.
Nevertheless to be sure I downloaded the file in the thread about the bug. With that file the selection indeed works. With a more complicated file (a more complex collection structure) it doesn’t work with the same settings. Now I don’t know whether the fault is in the existence of nested collections as someone mentioned in that dialog, or what other reason.
I gave out trying and rendered in different View Layers which I composited.

I have no problem with nested collections with a very simple scene.

But that is probably the reason.
There are many basic operations related to collections that are not handling nested collections, yet.
I would not be surprised if that is also the case for Freestyle.

Hoping it isn’t against the rule to reply to old threads… I just wanted to report that I have the same problem as @csimeon where Freestyle won’t render a collection if it has more nested collections inside of it.

It was driving me absolutely nuts the whole day yesterday and then today I thought “could it be the nested collections…?” I ungroupped the collections inside the one I wanted to render and boom, it worked.