Frequent crashes with Eevee in Ubuntu

Hello all, I’m wondering if you can help me. I’ve been experiencing crashes of my graphics card/drivers when rendering any scene in Eevee (either in the viewport or actual render) in Kubuntu 20.04 on my Radeon VII. It always works fine at first but after a seemingly random amount of time my enitre PC freezes for a few seconds, then both my screens display corrupted ‘pixel vomit’ over everything. I can still interact with various apps and the KDE interface, but I can’t see what I’m clicking on. On reboot everything returns to normal. I’ve been experiencing this problem on and off for the past few months, but the crashes seem to have become much more frequent, and Eevee is barely usable at this stage.

I’ve found that trying to view or render a scene with very complex materials will crash it within a few seconds (but not before it compiles shaders, and it always works at first), however it will eventually happen even in very simple scenes. I have tried rendering the same scenes in Kubuntu 20.04, Linux Mint 19.3 (both Ubuntu based and different kernels) and experienced the same problem. On the same PC the scenes render fine in Windows 10.

I have checked VRAM usage in windows and none of the scenes tested got anywhere near the 16GB on my Radeon VII. Temperature and GPU voltage in Kubuntu are always fine before the crash.

I have tried disabling the compositor (openGL window effects) in Kubuntu to no effect.

I have tried installing the official Ubuntu drivers for my graphics card from AMD’s website, and instead of the crash creating this ‘pixel vomit’ effect, the screens simply turn black except for a few elements (title bars on windows, things like that).

I have tested multiple versions of Blender from 2.80 to 2.90.

I have not experienced this issue in any video games.

At this point I’m a bit stuck, as I do all my rendering in Eevee and have done since it came out. Now even old scenes that never gave me an issue will crash my PC within a minute of using Eevee. It’s quite evident to me that the complexity of the materials has a direct impact on the likelihood of a crash (even a single, lowpoly object will cause a crash with a complex material), but I’ve always made complex materials, and the fact that they will always work just fine for a moment before the crash and that they work perfectly in Windows means something’s going wrong somewhere.

I’d be very grateful for any ideas. Thanks in advance.

Kubuntu 20.04.1, KDE desktop
AMD Radeon VII, 16GB VRAM, default Ubuntu drivers
Intel i9 9900K, 64GB RAM
Gigabyte Z390 motherboard
850W PSU