Hey everyone, i’ve been learning from CGCookie on animation, and well i’ll do my best to explain what is going on.

I lay down my 1st animation, is set down a location key on frame 1, I skip to frame 11 and move my armaments to their proper place and lay down a location key, and as i review it, none of the keyframe from frame 1 has appeared to taken affect.

Liek my keys from frame 1 are from frame 11.

What am i doing wrong here.

EDIT: I found out the problem I had the “Show auto key warning” in my user preferences checked, which was causing the problem. Sorry everyone.

Don’t be sorry Jncocontrol, I’m going to be animating sometime soon and needed a fair warning. In fact, thank you for giving me less of a headache in the future.

There’s nothing to be “sorry” about in discovering that there is an “obscure user-preference.”

Why don’t you post another summary to this thread … for the Gentle Reader who inevitably will follow you. First, describe what you were seeing and why it flummoxed you. Then, describe the user-preference that you eventually found to be the problem, and how you found out that this was it. Then, quickly summarize it all once again for those who like to read only the last paragraph. :slight_smile:

Nothing’s worse than banging your head against something. (That’s a very big reason why sites like this one exist.) Write the summary that you wish you’d been able to find, so the next bloke will. Thanks in advance.

I don’t know what the problem was, but it wasn’t this. That preference only affects whether a warning is displayed in the top right of the viewport and has no effect on what keyframes are recorded.
Perhaps your issue was only setting a location keyframe. I would suggest that you set a key on the whole character on frame 1. This will record location, rotation and scale for all the appropriate controllers in the rig.

Also, this section of the forum is for posting animations, not for tech support.