FTGL/freetype and building from source?

I’m wondering what the process is for getting the " use_international = ‘true’ " in SConstruct under gentoo linux to work.

I just get his error when building blender:

g++ -pipe -funsigned-char -march=athlon-xp -O3 -Wall -W -DGAMEBLENDER=1 -DUSE_SUMO_SOLID -DNDEBUG -DFTGL_STATIC_LIBRARY -I/usr/include/freetype2 -I/home/nallworth/Blender/CVS/blender/new/blender/lib/linux-glibc2.2.5-i386/ftgl/include -I/home/nallworth/Blender/CVS/blender/new/blender/build/linux2/source/blender/ftfont -Isource/blender/ftfont -Isource/blender/ftfont -I/home/nallworth/Blender/CVS/blender/new/blender/build/linux2/source/blender/ftfont/intern -Isource/blender/ftfont/intern -Isource/blender/ftfont/intern -I/home/nallworth/Blender/CVS/blender/new/blender/build/linux2/source/blender/blenkernel -Isource/blender/blenkernel -Isource/blender/blenkernel -I/home/nallworth/Blender/CVS/blender/new/blender/build/linux2/source/blender/blenlib -Isource/blender/blenlib -Isource/blender/blenlib -I/home/nallworth/Blender/CVS/blender/new/blender/build/linux2/source/blender/makesdna -Isource/blender/makesdna -Isource/blender/makesdna -c -o /home/nallworth/Blender/CVS/blender/new/blender/build/linux2/source/blender/ftfont/intern/FTF_Api.o source/blender/ftfont/intern/FTF_Api.cpp
scons: *** [/home/nallworth/Blender/CVS/blender/new/blender/build/linux2/source/blender/ftfont/intern/FTF_Api.o] Error 1
scons: building terminated because of errors.

When I try yo build and install FTGL I get this error (portage the gentoo package manager/repository doesn’t contain FTGL. thus I’m using vanilla source from http://homepages.paradise.net.nz/henryj/code/#FTGL ):

$ make
for d in src demo docs ; do make -C $d all ; done
make[1]: Entering directory `/home/nallworth/Downloads/FTGL/unix/src'
Makefile:78: *** missing separator.  Stop.
make[1]: Leaving directory `/home/nallworth/Downloads/FTGL/unix/src'
make[1]: Entering directory `/home/nallworth/Downloads/FTGL/unix/demo'
/bin/sh ../libtool --mode=link g++ FTGLDemo.o tb.o trackball.o -o FTGLDemo ../src/libftgl.la   -lfreetype -lz -lglut -lGLU -lGL
libtool: link: cannot find the library `../src/libftgl.la'
make[1]: *** [FTGLDemo] Error 1
make[1]: Leaving directory `/home/nallworth/Downloads/FTGL/unix/demo'
make[1]: Entering directory `/home/nallworth/Downloads/FTGL/unix/docs'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/nallworth/Downloads/FTGL/unix/docs'

Thanks for the help!

there is a switch somewhere to disable antialiased fonts in the build

put “export WITH_FREETYPE2 = false” in your user-def.mk

Blender uses its own version of FTGL. The source must be somewhere but I couldn’t find them after a quick search. The /Lib folder in cvs contains compiled FTGL libs for all versions (IIRC) so you could start by using those.

Martin

That’s basically what I’ve been doing but I want to enable it.

Thanks theeth, I’ll see what I can dig up!

:smiley: edit:

[email protected] blender $ cvs -z3 -d:pserver:[email protected]:/cvsroot/bf-blender co lib