Full-screen shortcut on Mac

Hi all. I thought I’d utilise this lockdown period to try learning Blender, for the third time.
Unfortunately I’m stumped already. The keyboard shortcut of Control + Spacebar to full-screen the active panel doesn’t work. It enables ‘spotlight search’ instead.
Is there a setting I can change in either the mac or Blender to fix this? Mac version is 10.15.3.
I’ve looked at and played around with the Keymapping preferences in Blender but had no luck (screenshot attached).
Much appreciated. Thanks.

Are you using the control key and not the command key? Command + spacebar should bring up spotlight search, while control + spacebar turns the area full screen.

Thanks for your input. Yes, I am using the control key. The Command/spacebar combination is assigned to controlling the Japanese Language input I have on my mac. Perhaps that’s the problem?

I answered my own question by disabling the mac keyboard shortcut for control/spacebar and it works now. Cheers.