Fullscreen resolution problem in UPBGE 0.3

Is there a way to set a fullscreen resolution in UPBGE 0.3? I’ve been trying to change it in the options, but I always get the desktop resolution, and changing it using python, just gives me a small windowed and borderless window letting me see all the windows desktop and applications, I even tried using a .bat file with the args, and all of the attempts works on windowed, but for some reason they don’t work in fullscreen.

the fullscreen thing has been a trainwreck for as long as ive been using bge. theres little you can do about it

it worked fine for me in blender 2.x and wanted to add the option of a different resolution in fullscreen for my project in UPBGE 0.3 but if there is no way to archieve it, I should discard it.

Never worked for me (amd user), i never could change the resolution in fullscreen, however you can just uncheck fullscreen and set the resolution you like, but then your in windowed mode and not in fullscreen anymore.

How it is in 0.3.0, no clue, not using it for projects.