Funky EnvMap glitch


(ace4356) #1

Ok folks, new problem, (I’m getting annoying aren’t I?) I have figure dout envmaps. I am trying to make a battery model, to learn how to use them well enough for my sword. However it sems to be glitchy, certain parts of the cylinder envmap arent gettign anything and are just blakc. It’s weird, not sure of problem, I check my settings against the turoial and can’t find problem. Attached is my blend file, this way oyu can see problem. If you have a solution please explain it to me and don’t just fix it in blend. I wanna learn how to use this cool program.

TIA,
Ace


(wewa_juicyb) #2

uhm just curious, where is this attached blend of yours…?

WeWa


(valarking) #3

Mebbe the glitch isn’t with the software, but with the user?


(ace4356) #4

Oops, sorry I had a headache so my thoughts were fuzzy. And I am not saying it’s the software. I am pretty sure it’s me, I was jsut hoping someone could tell me my mistake so I can learn fro mit. :slight_smile: Attaching file now:
http://www.angelfire.com/realm2/aceblender/battery_envmap_glitch.blend


(theeth) #5

Select the mapping mode (green buttons) called Refl instead of Orco (all of this in the Material window).

Martin


(ec2) #6

First , your env map texture coordinates aren’t set to Refl, its set to Orco, so the mapping isn’t displaying on the battery correctly. Second you have the battery in an environment which consists of a textured (quite colorful)cube with the top and one side (faces) missing. So the area out side of it is black. So your reflection (env map) contains the reflection of the cube texture and the black area outside the cube.

Try setting the Filter on your map to .10 (sharpest) and CubeRes to 500 or better.

I hope this helps.


(ace4356) #7

Thanks guys, it works now, can’t believe I missed something so simple. Well unitl tomorrow

Hapy Blending,
Ace