Funky rendering problem

I’m working on a graphic of a compass (still in early phases.) It looks fine when I render in 25% mode, but when I click 100% it is all screwed up (images and blend attached.)

I’m using Mac OS X Snow Leopard. I tried it with both 2.49a and the 2.50 alpha, both gave the same result. Nothing fancy is on the image, I have one spotlight, raytracing turned on, and there is one image texture on the face of the compass. Any ideas?

Attachments



compass2.blend (276 KB)

Figured it out! There is a glass dome over the compass face and for some reason it was casting a shadow on the texture. I moved it to another layer and then told the light only to cast shadows for objects on its own layer. Problem solved!

Another way is to turn on “transparent shadows” for the any material that is supposed to recieve glass transparency shadows- otherwise it will render as if its not transparent on other textures.