Funny shading in raytracing?

Hi all, this is my first post - hope someone can answer this. I am modelling an aircraft using meshes. What you see below is a close-up of the engine detail. Not all of it is present, so some of it looks funny, however, I figured out that I could not get shadows unless raytracing was turned on. The shadows look so-so and I will tweak the lighting a little to get the right look. The problem I have is that in a couple of places where the light ‘rays’ are paralell to a face, the render doesn’t know what to do about it and makes the face entirely black. You can see this as a long black line on the side of the engine, and in an area where the engine strut blends into the engine at the rear. Also, inside the exhaust cone, the shadow begins, but then the bottom inside is shaded white, which is impossible. I thought maybe the cone issue may be because it is a single face and one side is the inverse Z channel of the other side. I tried making the faces single sided, wby turning off the enabling button, but this makes no difference. Any suggestions on how to prevent these lighting artifacts other than to light it at a better angle??

http://img69.exs.cx/img69/5531/engine8.jpg

In edit mode, select all vertices and press Ctrl-N, recalculate Normals Outside. That should solve it.

I tried that before, but I tried it again just for sh**'s and giggles. The normals are all facing out and the black lines are still there. I will move the light slightly and repost the same camera angle for comparison. Here is the same view with the light moved slightly; notice some of the black lines are gone except the one on the side of the engine. It has moved down some and to the right. This only occurs where the rays of light run parallel to a face. Strange indeed:

http://img92.exs.cx/img92/4714/engine6.jpg

The same thing occurs on other parts of the model as well - all on faces that run parallel to the light.

http://img73.exs.cx/img73/8201/fuselage.jpg

I assume you checked the normals also visual, with Draw Normals on? Another cause may be some extra geometry like double vertices, or an extra edge or face. Check the geometry carefully at those places.
Let me know if you found something

Yes, I checked the normals. I finally solved this one. Turns out I somehow copied my lamp and had two lamps in the same spot - looking like one lamp. I had a spot and an area lamp. I removed the area lamp and it works fine now. Here is the same model without the area lamp on top of the spot:

http://img18.exs.cx/img18/2628/test7rf.jpg