Fuzzy Sequencer Output on Linux

I do a lot of video editing in Blender, and the past few days I’ve been trying to migrate over to Linux (Ubuntu 10.04). My problem is that when rendering from video clips, I get a fuzzy image.

This is the exact same video clip rendered in Blender 2.49b on both systems.


It happens with every video codec I’ve tried, even raw video. 2.5 is no better. Image sequences look fine. Any ideas on how to fix this? I really want to be able to use Linux, but this is somewhat of a dealbreaker.

EDIT: I tried 2.48a, and it works perfectly, so apparently it’s an issue with 2.49 and on. I would really like to be able to use 2.5, though, so I would still appreciate suggestions.

This is problem which has been discussed both on this forum and on the Blender bug tracker site.
ffmpeg appears to be the source of the jugged edges problem.
I’d certainly recommend moving to Linux from windoze.
You can solve the problem by installing the latest ffmpeg from source following the detailed instructions provided by this guide:


Once you compile ffmpeg you can use Blender 2.5x on Ubuntu 10.04 without problems.

Thanks for answering. =)

I followed the instructions and compiled without any problems, but the problem is still there. Should I be using a specific Blender build?

The problem persists?! Oh?
I’m on Kubuntu 10.04, have compiled ffmpeg from source and use the latest builds from graphicall.org without problems. You could try and download one of the builds from graphicall.
Btw Is your system 32bit or 64bit? Download the correct version.
Are you using any compiz effects? If so, disable them and try again.
Are you using full screen anti-aliasing? Maybe a good idea to turn it off and check the render results.
What’s your graphics driver? Does it offer full 3d support? Are you using a generic driver for X or are you using drivers provided by the manufacturer (if any)?

I just hope that these problems don’t discourage you from adopting Linux.

I compiled the latest ffmpeg and am using a recent Graphicall 2.52 build, a 32-bit build on a 32-bit system, no Compiz effects, no anti-aliasing, and the most recent NVidia driver.

Well, in that case, I run out of ideas! :frowning: