Fuzzyness in rendered Animation /particle system problem

Dear beloved Blender-Community,

as an archaeologist I got a commission to produce a small 3D-Animation/reconstruction of a Neolithic village, but never produced a model in such a big scale in Blender. But thanks to Covid-19 I had a lot of time figuring out stuff… At the end I produced a small Video, which will be open access and shown on a display in a small museum in Germany.

Now I’m already at the final stage and trying to render the image sequence for further post-production of the video (like embedding text and credits).

A short scene of the video: https://vimeo.com/494843849 (wait for 1080p to load)

But I am getting quite fuzzy video – especially the vegetation (trees and grass, generated from single models via particle systems) is very fuzzy, the pixels are jumping from frame to frame, and I don’t get a clear picture. Only the vegetation has this anomaly, all other materials are not fuzzy at all.

I know that Cycles is fuzzy at times, but I don’t know how to improve the quality anymore.

Do you have any ideas how to reduce these jumping pixels? Does it stem from denoising, the number of lightpaths or samples?

All the best,

Mantorok

My first impression is that your problems are coming from viedo codec / compression. But it could be related to transparency bounces, or something else.

  1. Can you show your render settings for output images (or video) You are better off rendering to images, .png or .exr and as your very last step converting to video and uploading.
  2. Are you using blender denoiser (you should be) and you can probably lower your render samples down from 2500, you usually don’t need samples that high, probably 500ish would be fine.
  3. WHen you view the video file on your own computer (before uploading to vimeo) how does it look.
1 Like

Hi, i would first suggest rendering to an image sequence. That way you can see frame by frame and no suprises in video quality. Also lower samples and use an hdri for lighting. Do not de noise until after via the composotior. Lastly denoising quality for openimage denoise is the best but you want to animate the noise as well so it looks less cg.

1 Like
  1. The output are rendered .jpg-files, which I convert in a second step into a video file (see screenshot below) - I can try to set the output to .png or .exr in my next run!

  2. I deactivated the denoiser: in the end the frames seemed to less fuzzy without the denoiser. The difference between 500 to 2500 samples was only 10 seconds on my system and the overall quality does not improve with 2500: you are right, I can put them back to 500 without loss of quality and save some minutes

  3. The video is fuzzy before I uploaded it on Vimeo -> To make that visible I just put three frames into the post - as you can see the pixels are already skipping from frame to frame, before I render the image sequence into an animation :confused:

Thank you so much!

here they are - three frames in a row: In the moving video these jumping flies are quite noisy and made some of the test-watchers seasick

Try rendering a few frames to .png instead of jpeg and then converting them, and see if that fixes it.

1 Like

looking at those frames, they are way noisier than they should be, even with jpeg…

@Photox I rendered some frames with .png instead of .jpeg - but sadly, the noise-anomaly is still very strong

There is a problem with the amount of noise in each frame, is there any way you can strip down the scene to just a small patch of grass, and upload a packed blend?

1 Like

@Photox of course, I just packed you the patch of grass into a .blend, including the particle system. It is similiar to the project’s particle system, just scaled down

OK, so the screenshot from the very first post, clearly shows you are using cycles, with 2500 samples. The file you uploaded is eevee. When I render a frame in the eevee one it renders clean, I haven’t tested video, but it look snothing nothing like the render tests you showed, which are almost certainly cycles. What are you using, cycles or eevee? CAn you upload a smaller version of the real file that produces the noisy images?

1 Like

Yes, I am using cycles. I just forgot to implement the render preferences into our small test-file (sorry)

I now uploaded a test-file with the correct render preferences and a part of the environment/vegetation of my project - I hope this is might be more helpfull to find the orign of the anomaly

To provide you with some context, this is how my final render will of the project will look like (without the noise-anomaly of course)

try this:
in render properties

  1. uncheck ‘adaptive sampling’
  2. lower samples to ~150 - 400
    after that, I would enable the denoiser (just below it), although you might want to do that later in the workflow.

That is much better, thank you my friend! Still a bit noisy, but overall much clearer - I think that might solve it. I learned that AS and high render samples are not usefull in this case:

1 Like

Good, did you ever try the denoiser on it?

On a single frame is it clearing the picture even more, but regains a stonger noise-anomaly in the Animation