Game actuator bug.

Hello m8s, long time no see :cool:

i recently discoverd a little bug with the Game actuator.
When the other blender file is loaded it has turned of Mipmaps, witch can be a major problem(slows down alot on some scenes). Is it just me?
annyways i wasent sure where else to post this.


I have this problem too. Actually, in my case, mipmapping will not work any time you change scenes. And I don’t think they work at all in a .exe.

Anyway, I’m not sure how many people have this problem. Everyone always ignores this question or blames it all on ATI video cards or outdated drivers. But I know that other vc’s also have this problem. A bug report was filed some time ago.

I can’t confirm the extent of the problem, but now you know you’re not the only one.

My video card is an ATI 9500 128bit (a bit dated). You and anyone else having this problem should list your video card type on this thread.

I have this problem too. Actually, in my case, mipmapping will not work any time you change scenes. And I don’t think they work at all in a .exe.

Mipmaps seem to work for me when I switch a scene… but than again, I haven’t played with them much.

But I do know that mipmaps are disabled when you make an exe file. However, you can enable them in an exe file if you run a dos command - I can’t remember what it was, though.

Yeah, I’ve tried to enable them with the command prompt, but it still doesn’t work. Depending on what type of textures you use, it’s sometimes hard to notice if they’re working or not. It also depends on how you have your graphics card set up. For example, I can turn up the Open GL graphics quality for my card, and you can’t tell because it smooths everything out. Problem is, performance suffers greatly and with Blender already being on the slow side, you know… it isn’t good.

Could somebody upload an example where this bug could be clearly seen? I tried switching them on and off with the ‘-g nomipmap’ command, but I didn’t see any differences.

The best way to tell is with a texture like asphalt. Also, I think Blender Materials have to be on (not sure though because I always use blender materials). I’ll try to post an example later.

Actually I used asphalt texture and tried with and without Blender materials. I took screenshots with mipmaps on and off and compared them, but they were perfectly identical.

I suppose this is why the issue of mipmapping is what it is. Nobody knows for sure (and for the reasons I posted above).

Anyway, according to the documentation, mipmaps are supposed to be on by default (for .exe and blend). Usually, I can easily tell on my monitor. I know there is definitely a problem with mipmaps and BGE. If this problem is cross-platform and/or exists in all video cards, I don’t know. The problem is strange and exists whether running .blend’s or .exe’s.

I had a look at the example blend in bug tracker and noticed the texture wasn’t properly loaded: ‘Texture type’ was set to ‘None’. I fixed that and the mipmaps work again. I wonder why the texture was even visible in Blender, when it wasn’t really loaded…

Could you provide the blend or a link?

Sure, here’s the original report:

Here’s my fixed version:

you test mip mapping by using a checker texture and a pig flat plane…

pretty obvious if it’s not working…ie. if it’s working it looks rubbish with blended lines towards the horizon… if it’s not working the texture will be crisp. mip mapping increases the realtime render speed. for some textures like wire fences it is better to turn off mip-mapping… of course being able to do this on individuals objects would be nice as well as using the newer samplers like tri-linear filtering…

Thanks very much. I can see the difference. It appears then that this problem is unique to my video card. On some textures, I get what looks to be a ‘speckled’ effect which I believed was a mipmapping problem (and it is probably related). It’s too subtle to notice with a screenshot but annoying when using a FPS or similar camera-rig on some textures. I’ve been tweaking the textures to compensate.