Game Engine crashes Blender!

hi guys!
im a noob on blender, but i wanted to try out the game engine.
the problem is: when i got my game ready and press “p” in order to start the game engine, my blender crashes and there’s a window saying that blender has to get quitted.

im sure there’s already a thread in which this question is answered, but the search-function of the forum didn’t give fitting results and i hope, anyone can help me…
oh, and my OS is windowsXP, blender version 2.45

looking forward to your answers :slight_smile:

Have you tried a reinstall?

What kind of graphics hardware do you have, and does it have the latest drivers?

If you post the .blend file we can test it.

Hmmm, using the forum search sucks, this is true. Use google advanced search and put the URL, as a site parameter.

You will get much better results.

OK, now what is in your scene? do you have several models? Just a couple? We need more information.

Does it work with only the default box model?

Most times when the GE crashes it has been because a model in the scene has duplicate vertices. The GE cannot manage duplicate verts in the same space of one model, and it will crash fast, with that same error.

So check that, and be sure to always remove duplicate vertices. This happens a lot when a user copies a model from someplace and then makes changes to it.

Sometimes verts get tucked underneath and you dont even notice them. An easy way to get this taken care of is to join them with ctrl-m.

Hope that helps and you dont have to install again.

try to install blender 2.42a or 2.41 try that i have to uninstall 2.45 i when back to blender 2.42 a i lke 2.44 its nice but it have bugs to fix but next year it going to be blender 2.50 update: cs exporter now cs going to come with blender and newer logic brick 2d ,particles and more… i can’t wait :slight_smile:

ok, this is the .blend file, an easy test of the rolling physics:

my graphic card is an VIA/S3G UniChrome Pro IGP , wich is an integrated graphic chip with 64 mb shared memory, i installed the latest drivers for it, directx 9.0b is installed…

oh, and it doesn’t matter what is in the scene, even if there’s only a camera and a light, blender crashes…

it’s the same, when i save the file as an EXE, cause then the EXE crashes

EDIT: i installed blender 2.42a, it’s the same problem

ok, i think, it’s my system which just doesn’t like blender-maked games…
i’ve downloaded a game made by someone else and had the same error… now i’m just wondering if it’s the graphics card or somethng else in my computer… is there any known incompatiblity between blender and some specific hardware?

i think it’s ur graphics card (im not sure) maybe u have to buy a better graphics card (nvidia or ati nothing else!!)

ok, i think i have no choice… thanks anyway to everybody who tried to help me…
settling over to opengl till i have enough money for a better graphic card

Yes, It is probably your integrated card. I have one similar and it just doesnt have all the bells and whistles needed for most games. You should notice that games like longest journer or unreal run slow and drag a lot.

I installed a nvidia 6600 and love it, I think I paid only 120 for it september 06. You could probably get one similar, but cheaper now. Check online.

Also notice some ati cards have some problems with blender, or vise versa. So maybe stick to nvidia? Mine was an asus.

Good luck.

Default windows drivers are not always the best option for games. Before blaming the card try installing the latest drivers from the manufacturer site.

my graphic card is an VIA/S3G UniChrome Pro IGP , wich is an integrated graphic chip with 64 mb shared memory, i installed the latest drivers for it, directx 9.0b is installed…

As far as I know Blender does not use DirectX but OPENGL.

Good luck.