game engine export to runtime no texture showing

When I export to runtime (even after packing) textures do not show and even many objects do not show. I am using blender 2.6a.
I have the interior of a sphere textured with an image and another object (the floor) textured (also with an image).
The textures show in 3d view and after pressing P, but not in the exported game/.app.
Also, when rendered in blender render, the textures do appear.
Can anyone help?
I am using a mac osx 10.7.2.

Are the images “packed” into the blend file? If they aren’t hit file - external data - pack in .blend and save it :wink:

Yes RossBlenderArt, they are packed. This is what I meant by “(even after packing)” in my post.

What is also strange, is that the objects themselves, the floor, the uvsphere (globe), and a building on the floor, which has no texture do not appear. Actually, all that appears is the character. All I am trying to do is a simple monkey that throws balls at a wall game.

Maybe you could upload the .Blend so we can look at it? Thanks.

I would like to, but I am having a problem doing so with the file upload manager of this site.

Link to a mediafire? ;(

As far as the packing goes, I took the .blend to another computer and it had the textures, so I presume they were packed properly.
This other computer was operating windows 7, so the issue is not peculiar to a mac. If you have any suggestions with the upload please tell me. The file size is under the permitted 15 mb.

here you go -
by the way, thank you for your time and interest

Textures appear fine for me, jozer. I downloaded your blend file and then saved it as a game engine runtime. It ran fine after that and all textures appeared normally.

I saved it as a runtime using Blender 2.60a on Windows x64, oh and by the way, your game has a very obvious slowdown problem when the planks start falling and the physics kick into effect.

I’m glad it worked for you, but that doesn’t help me any. Unfortunately, I never got so far as to see planks falling in the runtime to notice the slowdown.
I tried this on windows 7 x64 as well with no luck.