Game engine LIGHTS: why is lighted by default?Expert needed!


So Game engine question again…

I have the floor of my Game engine interior which is LIGHTENED.

I have remove all lights…
The walls are ok: they become dark, limit black.
But the floor is still lightened.

What I want to achieve is:to have black so I can Adjust the lighting properly.

I join a picture of the situation.

The wooden floor and the marble should be both dark! Why are they lightened?:confused:

I presume it has nothing to do with AMBIANT LIGHT: the 3 sliders (AmbR, AmbG,AmbB) are set to 0.
(The World Buttons also contain the sliders to define the Ambient light. The effect of Ambient light is to provide a very simple alternative to Global Illumination, inasmuch as it lights up shadows.)

I would add 2 captures:

This is on the blender view: light is emitted by the spot, propery. Everything is black execpt on the “spot influences area”.

On the game engine by pressing P: Light is set properly to the wall, we can “see” a spot… BUT the floors are lighted… but no lights act on them??? :confused:


Do you know how to change the faces so that they are shaded by the light? If not, select your object then go into uv face select mode. select one face and go into the edit buttons then to the texture face panel. In there just hit the light button. now select all of the faces on your object and hit copy draw mode.

Try subdividing the objects with the light problems and see if that affects it.
And when the game starts the lighting changes in every game.

No i am affraid I dont understand everyting…
It sounds like what you says is: I will replace the face by a face shaded?
So it will reproduce the light effects created on a “normal mode”?

i have a black wall with a spot light in the middle.
I am going to copy this “face+the light/shadow effect on this face” to the normal face, so in the game engine its reproduces it, like a simple textured face.?


I also didnt find all the options you said to me especially “GO INTO THE EDIT BUTTON”

Step one:go into uv face select mode is:

Step two:go into the edit buttons then to the texture face panel (??)
is that:

Many thanks!!!

ps: I try to find the solution by myself, but I spend an hour without success… need your “lights”! :slight_smile:

I selected the floor, went into edit mode (tab) then f9 for mesh toools then i subdivided all that several times.

I tried with “p” game engine running but still lighted.

I tried just in case to inverse the normals inside, then P then outside then P.

the texture is applied properly but light from i dunno where!
and I dont think i have a hidden light somewhere as te walls are black, everywhere, even the objects/

Must be a small detail I dont know!

HOP! I managed to find your options:

The floor face was not set as “light before” anyway…
but it is still bright!:eek:

make sure “light” is enabled, and “shadeless” is NOT pushed down in the materials buttons

Shadeless is disabled (not pushed down).

“Light enabled” where abouts?
But I remember that all other objects or walls, are becoming black, without the lights, excpet the floors.

I turn the sky to black to try but still the same.

Is it possible that the texture itself is bright so its is coloured? I think it is the solution as it is the only textured objetcs that I have!
the walls are materials.

the “problem” is probably just that all texture surfaces are lighten by default… or has the texture colour for the light…
im trying to figure out that!

But not tonight, its 3am on the moning up there so time to get home and sleep…!

I will post my findings to help new users if i find the solution!

In face mode select all faces and press W then click Set…light.

Hey, I posted on your other thread about radiosity, but in case you didn’t see that yet, I’ll tell you here as well. I get the impression that you want to create a custom lighting atmosphere by illuminating certain areas with different lights. You can do this very easily with Blender’s radiosity function, but it is a bit tricky to learn. Social posted a link to a tutorial on using radiosity on your other thread. If you don’t have a copy of the HTML version of the Blender 2.3 manual, download it from’s documentation page. It will be your new best friend. Read the Ch. 18 “Radiosity” to learn how to produce what you’re looking for. You can still apply textures to your radiosity solution the same way you did to the original meshes.

is better to use this

dowload a file Lighting maps.rar

they are three examples :

Light uv
Light maps (alphas)


Hace mucho tiempos que no ha hablado espanol, pero GRACIAS!

Voy a mirar tus tutoriales!

i said in Spanish, that im going to see the tutorials he put the link for, :slight_smile:

I think I foudn the solution myself!!!

the textures has some BRIGHTNESS! (tab “color” in texture mode)
if you lower this natural brightness, the texture become black as the others materials/textures…

It was SO simple!

well i found myself many solutions/reasons>

-lights(lamp) put on another layer than the one whre the objects are
-brightness on the texture (under the texture button/color)
-material itself too bright or reflecting too many light
-ambiant light of the world (check world setings)

-yaffray power emitting values

hope that help to start to understnd!