Game Engine Stretching When Export Runtime

When i export a runtime, not fullscreen but windowed, it stretches my view.

I have 4 scenes, it works fine in the first scene i created but in all my others it stretches when i switch to them.

Any ideas?

It also says that i dont’ have python bundled with the exe. could this be the problem?

I don’t think so. I definitely am having this problem, too, though. It kind of destroys any chance of a demo for me…

This is a Blender 2.5x bug. If you create a new scene then don’t use Scene --> New. You have to copy the first original scene with "Full Copy ".

I found that if you set the resolution to a perfect square (768X768) and put it in windows mode, it does not stretch.

Thanks, HG1, I’ll try your approach.

Meatlover, I’ll see if I can use that for my game, as well.

I just don’t like copy full, it creates duplicate meshes and materials.

That’s true, but if you destroy all duplicated objects and save the file, it should be fine (all duplicates are destroyed).

I have seen similar problems - and different on different computers with the same blend (they have different screen aspect ratio thou). Thanks HG1 and meatlover - now when we have a clue of when this happens and not the bug might be fixable - is it reported?

I ran some tests. This are my conclusions (2.57):

  • each scene has its own render settings (size, framing etc.) which is a little bit confusing
  • scenes added via “new” ignore the framing settings and default to “stretch”. I think this is the bug. It does not matter if you switch to this scene or start with this scene it is “stretch”. The resolution settings are used when starting from this scene - that is fine. But the camera in 3dview uses the ratio of the “Blender Render” resolution - which is a bit confusing.
  • there is no way to share the render settings at the scenes (like the world settings)

Monster

maybe its because newly created scenes uses default resolution while scene1 is some other resolution?:eek:

Exactly. I saw that myself - in a runtime, the camera’s aspect ratio is 4:3, regardless of how the Blender camera looks. Also, like you said, the scenes added do ignore the framing settings. Hope this gets fixed soon, since that’s a pretty major error. The render settings should be shared somewhere.

I’m having this problem with an existing project in blenderplayer.

To rectify I have had to create a new file with the default scene, append all existing scenes in from my “bad” file, create a copy of the default scene for each appended scene and then link all objects in an appended scene to the new scene and delete the appended scene.

Not nice, but doable.

1.x If you konw your orignal scene then copy it with “Full Copy” and delete all objects.
1.x If you don’t know your orignal scene. Create a new file. Delete all objects. Append the scene to you bad file.
2. Copy the scene with “Full Copy”.
3. Link the objects in the bad scene to a new scene.
4. Delete the bad Scene.
5. Do point 2 to 4 for all your scenes.

HG1 - So you append a good scene to a bad file, whereas I appended the bad scenes in my bad file into a good file.

I’m very pleased there is this workaround. Before, I was running blender in windowless mode with autostart checked which meant no AA.