Game Engine won't start

The game engine won’t start when I press p on my Vista 64 bit . . . it just freezes and "Not Respond"s. It used to, but one day this just happened. I tried updating my graphics driver and upgraded to SP2, but no luck. I’m afraid to system restore because I’ve done a lot of uninstalling and installing and a lotta work that would be reset if I do. The command console thingo just says:

Compiled with Python version 2.5.2.
Checking for installed Python… got it!
Detected GL_ARB_texture_env_combine
Detected GL_ARB_texture_cube_map
Detected GL_ARB_multitexture
Detected GL_ARB_shader_objects
Detected GL_ARB_vertex_shader
Detected GL_ARB_fragment_shader
Detected GL_ARB_vertex_program
Detected GL_ARB_depth_texture
Detected GL_EXT_separate_specular_color

Then it freezes. Anyone know whats wrong?

EDIT:
Neveermind, it starts, but a simple cube takes ages to start. This has never happened before.

Is this with the default cube scene? If not, maybe you should try to backup your .b.blend and then rename/delete it to get a fresh one, and test that. If the BGE takes too long loading a scene, it can appear to freeze.

A couple of other things to check:

  • Make sure you have no infinite loops in the your scripts, this will cause the BGE to freeze
  • Make sure you don’t have a lot of faces/textures. Maybe you were playing with a modifier or something and saved it as your default?

hi

i had been installed blender for 64 bits and the bge game crashed always , perhaps problem with the zip files of blender2.49B

so i ve been installed the blender 32 bits with the installer pack and so the bge goes ok

i think its the 64bits version who have problem with bge.

Ah ok thanks, deleting the b.blend worked. Sorry for the late reply, been busy.