Game Preview is Empty

Ok so I’m testing out some simple movement (I’m new to BGE) and everything is going great. I test out some rotation, it’s not good, I esc. out, adjust the rotation, and hit ‘P’. The game preview goes completely grey. I figured it was the camera so I go to the ortho view and hit ‘P’. It’s also grey! I can’t fix this! I’ve tried to search for this on the forums but none that I found had my exact symptoms. Maybe I didn’t use the right search terms, so sorry if this is another annoying post. Please give me some advice or direct me to a fix. Thanks!

I made a mistake that caused exactly what happened to, something else could be wrong but try this, with your mouse inside the 3d view hit MN and find the camera clipping settings make sure the clip near is like 1 and that the clip far is higher. Hopefully it helps, also try and get out of camera view and get your object in view then hit P without being at the cams point of view.

That worked! I tried messing with the clipping but apparently I didn’t do something right because it didn’t help before. Thanks for the quick reply!

I spoke too soon. It seems to be a bug with 2.57 when resizing the windows. But it’s odd that it doesn’t do it all of the time. Also it doesn’t just do it with the camera view. It does it from ANY view.

This is driving me insane! This is the 5th time I’ve had to start over from scratch because this stupid preview goes blank. And I can find absolutely no fix.

What OS are you using, and what version of Blender? In addition, could you provide a screenshot of both the 3D view in the camera view, as well as in an orthographic, ‘model view’ that showcases the problem you’re talking about?

Sorry for not being more descriptive! I’m running on Windows Vista and using Blender 2.57. I found that if I click on random items in the outliner panel and then hit ‘P’ that the view would be corrected, but I have to do it a few times before it works. It seems very random.

I can’t seem to embed the photos but here are the direct links:



My post disappeared I think…

Sorry for not being more descriptive! I’m using Blender 2.57 on Windows Vista.

I can click randomly on items in the outliner panel and the go back to the view port and type ‘P’ and the view will be fixed. But this isn’t always the case. I have to do it several times before it’ll work.

Here are the direct links to the photos, I can’t seem to embed them here for some reason.