Game speed and performance (specs provided)

Hello,

I am making a game and I have been trying to keep my models low poly, but every now and then when I run the game in blender (or as a runtime), the performance is quite poorly and it skips many frames (I haven’t even turned shadow on!).

I don’t think my graphic card is so bad that it cannot handle a low poly graphic game (well I don’t know much about computer hardware / Games such as The Sims 2 / GTA perform alright on my laptop)

I have seen some demo games on you-tube which looks much better and play much smoother.

Therefore I am wondering if there is anyway I can enhance the performance of my project on my machine.

My laptop’s specs:

Operating System: Windows 7 Ultimate 32-bit
Processor: AMD Turion™ 64 X2 TL-62 (2CPUs), ~2.10GHz
Memory: 3027MB RAM
DirectX Version: DirectX 11
Display: NVIDIA GeForce 7150M / nForce 630M

thanks in advance :slight_smile: :slight_smile:

BLender game engine is more heavy than other engines, and to make a smoth framerate you need to plan everything on the scenario, you cant just put all the objects on the same scene and wait that the game will work fine, I m not saying that this is your case, I m just telling you that you ll need to use of Occlusion cooling and LOD to make the game run fine, you ll need to plan about the textures and the amount of materials in scene as the amount of objects render in real time, you need to make shure that the textures fallow the scale pattern used on the games, for pysichs you need to plan the colisions and, well you need to plan everything!

I can tell you that this concepts will help you to improve the FPS:

  • Good quality UV maps ( Use the whole texture, if the object is static and is close to another object try to join this two textures in just one, this way you can control the shader individually using spec maps)
  • Minimize the bones and shape keys interactions ( try to use it whiselly because this can drop your framerate a lot)
  • When using filters allways configure their values, try to use a combination for better graphic results.
  • LOD system is indispensable to increase the FPS games with big enviornments.
  • Occlusion cooling is very usefull on BGE, try to learn about it.
  • Create a good light setup.
  • The low poly characters and enviornment isnt is allways the best option, sometimes you loose quality because of this, Sometime ago there was about 500.000 squares on my scene and the game was running at 30fps on the bge, but all them had no textures, you need to think about this, not allways the poly count is the responsable for the low framerate.

I hope this helps you, sorry about my english.

Graphics not only thing, that can lag, that’s can be physics, or even logic. Enable framerate and profile (game menu) and show us a screenshot.

For diagnosing performance problems in the bge, you can go to game -> view profile and frame rate. This will tell you what is taking up the most resources. How many lights are in your scene?

sometimes a driver update provides you with a “performance boost”. But without seeing your -blend it is difficult to tell what the bottleneck ist.

Thanks a lot everyone :slight_smile:

I have had a look at the framerate information
I seem to have a “physics” problem…

http://img822.imageshack.us/img822/4268/framerate.png

I think the best thing I should do is to upload the blend and anyone of you blender gurus who is interested can kindly have a look at it for me :slight_smile:

Thanks in advance :slight_smile: :slight_smile:

blend:
http://sites.google.com/site/felixc91/Home/StarterPython2.blend?attredirects=0&d=1

Moving - WASD
Run - Hold shift
Jump - Space bar
When main character is close to another character, a square will appear which indicate that user can push “Z” to interact

fixed! :slight_smile:
http://filebin.ca/adqrb/StarterPython2_fixed.blend

Bananaft, I do not know what you did because you are hosting your file on a questionable site (MVPS Hosts file lists filebin.ca as a vector for Win32/Olmarik.RF), so my computer refuses to visit it. Please forgive me if my response to kusohead duplicates your efforts.

kusohead, you are using “Ghost” on many objects here (specifically the player models and armatures) which should be using the “No Collision” physics type instead. I simply changed the Ghost objects to No Collision and the framerate increased from 4 fps to something like 220 fps.

Wow this is truly amazing! I don’t know how to thank you!!
I know no other ways than the word MAGIC to describe what you have done!
I can’t believe how much better it now runs on my laptop!
I have tried to find out the changes you have made, but I can’t find it.
It would be nice if you could share with me and everyone else your notion to the problem!

Thanks again :slight_smile: :slight_smile:

Ooh!..oops :stuck_out_tongue:
Now I get it :slight_smile: Didn’t know that make such a drastic difference! Thanks both of you.
This will encourage me a lot to keep the project going