Game speed ipo

I have a machine I made with the game engine. I’ve got each step of the process in a different file ( just to show my kids ) and one of the finished machine. I took an early file to record to the IPO in case I messed up, than nothing that I care about would be lost. The problem is when I did the finished version ( to IPO ) It is much slower. So I went to the Physics window an every thing is set the same!!! What is the matter. Plus I some how got the pop up window to only display object mode how do I change that back to the default window?"

Render buttons – FPS. Game speed is 60, but usually render speed is like 30 or 20.

I didn’t change anything and i have two different speeds in playback. Anyway do you know how I can get my pop up window back???

I didn’t change anything and I still have a faster playback for the one I don’t care about. I want the faster playback in the last version

just x-scale all the LocRot curves until it goes as fast as you want.

Not sure what you mean. If you mean all the moving parts of the machine I can’t because there is a ball that gets thrown in the machine and if I change the speed of the moving parts the ball won’t hit the next piece

no, switch to the ipo editor window and select the locrot curves, then ‘s’, ‘x’, scales the frames down, so it goes faster.

Ok… maybe I needed to explain this more, but I assumed that you had a little more knowledge of Blender. My bad.

The Blender Game Engine, BY DEFAULT, runs at 60 frames per second. For the “Record Game Physics to IPO” option, that means that in each second the game engine is recording 60 frames.

When you just play an animation, either by rendering it, hitting alt-a outside of the game engine, OR EVEN USING THE IPO ACTUATOR, it will run at the speed designated in the Render buttons (which can by found by hitting F10 or clicking the “Scene buttons” at the bottom, then “Render buttons” in the buttons panel) that’s labeled FPS. The default value here is 25. So instead of playing your animation at the correct speed (60 frames per second) it plays them at the incorrect speed (25 frames per second). If you increase this value to 60, you should be able to play it at the correct speed.



Ok I am new to this an a IDIOT on top of being a newbee. So i have a finished game ( machine ) that I want to move a camera around so whats the right order ? I move the camera, Hit I - locrotscal- enter. Till I have my path. At that point What comes next is it burn to ipo then animate or visa versa.

Oh yeah I cant spell for crap either!!!

on the main window, the one that shows all the 3d objects, look on the bottom left, next to the arrow next to ‘View’. click that little grid icon, then click ‘IPO Curve Editor’, and it will show you those curves i’ve been talking about. press ‘a’ until they’re all selected, then ‘s’, ‘x’, and that makes the frame amount smaller, so it animates faster. then, ‘g’, ‘x’ until the beginning of the animation moves to 1. then that line graph icon, bottom left, where the grid one was, then click ‘3D View’ to see the animation.

[there’s a much easier way than this to use the ipo editor, but this is the easiest to explain]